Failure to Integrate Zotero Add-on in Ubuntu Libreoffice

Hi, I'm having a lot of trouble integrating zotero into libreoffice. I installed zotero after libreoffice, checked that the zotero "libreoffice add-on" is enabled, and still cannot find the zotero toolbar in libreoffice. I also tried installing the extension pack file from zotero.org and install it in libreoffice as an extension, but while it prompts me to locate the file from the snap folder a pop up window appears telling me I have no permission to view the folder.

Fortunately I did get the firefox-zotero plugin to work so I can still import citations somehow efficiently, but it is just a hassle to not be able to import citations and bibliographies directly into the paper I am working on.

Both of my libreoffice and zotero installations are from the Ubuntu software store. I am running Ubuntu 18.04.4.LTS on a Lenovo pc.
  • What versions of Zotero and LibreOffice?

    See these steps and, if you're still having trouble, let us know what you've tried and what happened at each step.
    I also tried installing the extension pack file from zotero.org
    I'm not sure what you're referring to. The LibreOffice extension is bundled with the Zotero application and isn't something we make available for download separately.

    (Note that we don't provide a Snap package ourselves, only a tarball, so anything related to that we can't help you with.)
  • Hello,

    I have the same problem. My Libreoffice version is 1: 6.4.2-0ubuntu3 and my Zotero version is 5.0.85.

    I could open snap folder with the extension as a superuser (I have Ubuntu 20.20) when I tried to install as a extension from writter, but when I add the Zotero_Openoffice_Integration.oxt file, I have this message "java.lang.reflect.InvocationTargetException".

    My java version is openjdk version "11.0.7" 2020-04-14

    I hope you can help me with this. Thank in advance.
  • Did you try just copying the .oxt file out of the snap before selecting it in LibreOffice? LO is just going to copy it into its own directory, so the original location doesn't matter.
  • Finally I could solve the problem by installing libreoffice-java-common (It was not installed in my computer). I run this line at the ubuntu terminal:

    sudo apt install libreoffice-java-common

    and now zotero run perfectively. Thanks for your answer.
Sign In or Register to comment.