Cannot Install Word plugin - help...

Yesterday I updated my Office installation to the latest 365 version (before I had a retail Office 16 home and student).

Now I noticed Zotero was not working from Word, even though the tab is present. I went to Zotero to reinstall the Word plugin, but it gives me this error:

Installation could not be completed because an error occurred.

[Exception... "The file couldn't be opened because there is no such file. @[setTemplateTypeCreator:install.m:223]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/ :: checkStatus :: line 227" data: no]

What do I do? Where is the file?

I was running the beta of Zotero, now I also installed the non-beta (I renamed the beta to "Zotero beta") but this didn't help.
  • I think I have solved it myself, by copying the Zotero.dotm to the correct location.

    I have a feeling that the problem is the German language version of Word, where the correct location is:
    ~/Library/Group Containers/UBF8T346G9.Office/Benutzerinhalte/Startup/Word

    ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word

    Might this be the problem?
  • Open Finder, in the top menubar select Go -> Go to Folder and paste ~/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word into it and press Enter. Does it take you to the Startup folder? If not, what happens?
  • Yes, it does.
    In that case I don't know why I couldn't install the Word plugin from Zotero. Only manually copying the file worked for me.
    Now Zotero works fine.
  • Did you have any problems copying the file manually? Permission issue or other? Also is installed in the Applications folder (i.e. you are not running it from the disk image)?
  • No problems. I may have had to enter my admin password for deleting the Zotero.dotm file, but certainly not for installing it.
    I have both the beta and the full version of Zotero installed, see first post.
    Both are in the applications folder.
  • If you had to enter your admin password it means that your user account does not have write permissions in the Word Startup folder (or did not have the permissions for the original Zotero.dotm file). This could have happened if you originally ran either Word or Zotero as an administrator.
  • edited February 17, 2020
    I thought I was always running as admin, no? I am on a Mac.
    I also thought that having to enter an admin password for deleting anything from the library folder is normal, no?

    I certainly didn't log out or in between installing Word or Zotero, I am always logged in as the same user.

    Not sure I understand.
  • I also thought that having to enter an admin password for deleting anything from the library folder is normal, no?
    No, it's not normal for ~/Library. All files in there should be owned and writable by your user account and therefore not require a prompt. It'd be normal for /Library.
Sign In or Register to comment.