Add/Edit Citation editor coming up blank

I recently noticed a new issue while using Zotero (5.0.82) with Word (15.27 (161010)) on a Mac (10.13.4). When I attempt to edit an existing citation by placing the cursor inside the citation and clicking the Add/Edit Citation button, the editor pops up without the existing citation. It is as though I am adding a new citation, but the {Citation} tag doesn't appear in the document. If I do add a citation to the blank editor, when I hit enter, Zotero overwrites the previous citation altogether. There is one weird thing: the cursor in the editor is cut off when it first opens, with only the top bit visible.

I've tried selecting the citation in different ways: highlighting the whole thing, parts of the thing, placing the cursor at the beginning or the end. Occasionally, perhaps once out of every fifteen tries, the citation editor pops up correctly populated. Then, when I confirm the edit, the editor goes to the blue processing bar and freezes until I restart Zotero. Any ideas what is going on and how to fix it?
  • Can you reproduce this in a new document?

    Restart Zotero, create a new document, insert a citation, click on the citation, and click Add/Edit Citation. What happens?
  • When I close and reopen Zotero and insert a new citation in a new document, I get the same error.
  • Oh, wait, you're running an extremely outdated version of Word. Start by updating Word.

    While it may not matter for this, you're also running an outdated version of High Sierra. Even if you're not going to upgrade to Mojave or Catalina immediately, you need to at least upgrade to the last High Sierra point release, 10.13.6, just to have the latest security updates.
  • Unfortunately, I updated Word and I am still getting the same error!
  • To what version? And you should update High Sierra too.

    If it's still not working, reinstall the plugin into Word from the Cite → Word Processors pane of the Zotero preferences, and then restart Word and try again.

    If that doesn't help, provide a Debug ID for Zotero restart through the insert/edit process in a new document.
  • Okay, after updating to 10.13.6 everything seems to be working. Thanks!
Sign In or Register to comment.