Cannot Restore Zotero Data from Backup

I recently performed a reformat of my computer but now cannot restore my Zotero library. I was not previously using Zotero syncing, but have backup of the previous Zotero data directory.

I have checked the data directory location and it is pointing to the correct place.

I also tried to import the RDF file, but Zotero says this is not an accepted file format.

Things I've tried: uninstalling and re-installing Zotero, restarting my computer.

What can I do?
  • What happens when you try? What's the size of the zotero.sqlite file in your backed up data directory?
  • Only 940 kb. I think this is too small to be the actual sqlite file with the library I had built up before. My backup must've been wrong and I don't think I'll get my library back :(
  • yeah, 940kb is (not even) an empty library. are there any sqlite.bak files in the same folder? Any of those bigger?

  • There's one that's 4,576 kb but I tried to move that into the Zotero folder and nothing appeared in the library. I'm devastated that I didn't double check my backups before the factory reset.
  • That's certainly better -- so here are the general instructions: https://www.zotero.org/support/zotero_data#restoring_from_the_last_automatic_backup
    The basic thing to try would be to close down zotero, then rename a copy of the sqlite.bak file to zotero.sqlite, place that in the existing data directory (having move thecurrent one out of it) and restart Zotero. You should at least see something then.

    How large was your library, approximately (i.e. 100, 1000, 10000 items?)
  • The 4,576 kb file was not an sqlite.bak file, but a zotero.sqlite file. I followed the instructions but sadly still see nothing. The library had approx 1000 items.
  • It would be strange for you to not see anything at all if you're doing this correctly -- what are you seeing after restarting Zotero?
  • I see an empty library, and a Welcome to Zotero page.
  • edited 9 days ago
    Unfortunately both 1 MB and 5 MB can be empty databases, so that one might be empty too. Are there other zotero.sqlite* files in the directory? If so, what are their sizes?

    You should make a backup of all of them, and then upload the 5 MB one to the DB Repair Tool and post the Upload ID here. (You can ignore the download link the tool provides, but that will let us check whether it's actually empty.)
    I also tried to import the RDF file, but Zotero says this is not an accepted file format.
    What exactly do you mean by this? Which RDF file? This actually sounds like you have a Zotero RDF export of your library — rather than a backup — and tried to just point Zotero's data directory setting there, which would, indeed, create an empty zotero.sqlite database in that directory, since an export isn't a backup. Is there a 'storage' folder in there, and if so does it contain subfolders with attachments you added to your library? What other files/folders do you see in the root directory (along with zotero.sqlite)?

    If you did indeed export instead of backing up, can you ZIP the RDF file and email it to support@zotero.org with a link to this thread?
  • Hi dstillman, thanks for helping me. I uploaded the 5 MB zotero.sqlite file and the Upload ID is 5e4551ca65c1c. Unfortunately I cannot find any other zotero.sqlite files.

    I cannot find a 'storage' folder. I think my backup of the Zotero library was not correct and I do not in fact, have a backup of the library. I see "locate", "styles" and "translators" folders.
  • OK, yeah, that's an empty database.

    But then do you see an .rdf file in that directory? Do you see a 'files' folder?
  • Thanks for checking that for me. I don't see a 'files' folder. There is an .rdf file, which I've tried to import but was told the file format was not accepted.

    I think what happened is that I accidentally backed up an empty Zotero directory D: So this .rdf file would most likely be empty.

    I guess the only thing left for me to do is slowly re-build the library. Thank you so much for your help.
Sign In or Register to comment.