New clean, first time install of Zotero is lagging so much that it's unusable

I've installed Zotero the first time on my Windows 10 PC. The only thing I did was to start it up. And after starting, when I switch to the Zotero window, Zotero performs slowly. Not only is my mouse movement slow, but every action I perform has noticeable input lag. Even clicking on the menus.

More interestingly, there seem to be performance spikes. Zotero performs slowly 95% of the time, but there are sudden bursts of good performance where everything seems to be fine and perform how it should for a few seconds.

My PC is not old and every other demanding software runs fine.

If that helps:
D1615354257
  • That happened to me long ago, when I installed Zotero into a cloud storage folder on my computer. Is your computer, by chance, syncing everything you type both to Zotero's cloud and to another one?
  • edited 15 days ago
    User interface ready in 849 ms
    There doesn't seem to be anything slow logged in that debug output. It shows Zotero starting up in less than a second, and that's about it.

    But the kind of thing you're describing sounds like some lower-level interaction with your system, not anything in Zotero itself — e.g., Zotero obviously doesn't control your mouse movement. No one else has reported anything like this, so I don't have a lot to suggest here other than to try restarting your computer, disabling any third-party software you might have running in the background, and checking Task Manager.
  • (No, the debug output shows the data directory in its normal location. I don't think there are even any items in the library.)
  • Thanks for the fast reply. As dstillman said, I installed it in my internal HDD (but not in the same Drive as Windows).

    I tried restarting but no luck with that. Aside from the basic system drivers, I'm only running f.lux, OneDrive and my mouse + keyboard drivers. I tried closing down f.lux and made sure it's not running and then restarted Zotero. Still slow. I also made sure in my task manager that nothing else is running aside from my basic system drivers and the stuff I mentioned above. Still slow.

    Looking at my Task manager, nothing particular seems to use much resources. Zotero, when active, is using between 0.2% - 2.1% of my Intel CPU and around 130.5 MB RAM. Generally my resources are far from being overloaded.

    I thought maybe the only thing that might have an influence is the Hz of my monitor? My monitor is running with 144Hz with Displayport. I tried setting it down to 60Hz and Zotero runs slower than the 60Hz. And it's kind of inconsistent in its slowness, like it's not stably slow, it's varying and it's unpredictable. I don't know how slow it'll be when I'm moving my mouse.
  • Perhaps, try to uninstall and reinstall? Very baffling.
Sign In or Register to comment.