Word could not communicate with Zotero

I have just installed Zotero on my Mac (OS Catalina version 10.15.2) and whenever I try to use it on Microsoft Word (version 16.16.18) it says "Word could not communicate with Zotero". I have checked that the word plugin is enabled in the add-ons tab in Zotero. Please do let me know what needs to be done in order to fix this.

Report ID: 1774606762
  • Please have a look here and follow the necessary steps:
    https://www.zotero.org/support/word_processor_plugin_troubleshooting
  • Thanks! I already went through the guide before posting on the forum. The first three did not help and I dont know how to go about the fourth one (removing the no-remote command-line option). I have just been using the app from the applications folder rather than creating a shortcut on my desktop.
  • There actually aren't troubleshooting steps on that page for this error on a Mac, since this error doesn't generally occur on Macs. (The steps you're referring to were for Windows.) There've been a few recent reports of this on Macs, though, so something may have changed that's causing this.

    Have you tried restarting your computer?

    @adomasven may have other suggestions for what to try.
  • @hamsinibijlani: But to clarify, this was the first installation of Zotero on this computer? It wasn't ever installed previously?
  • It said "Word could not communicate with Zotero" the first time I installed it. Since then, i have deleted it and reinstalled it once again and it still says the same thing.
  • I tried restarting my computer and that hasn't worked either, still says the same thing
  • I am experiencing the same thing as @hamsinibijlani. same version of os on mac.
  • Could you produce a startup Debug ID from Zotero?
  • This is the Debug ID: D87493506
  • We have seen several users with the same problem with Zotero and Macs at our institution. I am looking into at least 5 different cases. One of our users is running MacOS 10.15.1, Word 16.16.18 and Zotero 5.0.82.

    I have tried reinstalling Word, Zotero, the plugin, checked the path of the plugin but I haven't been able to solve this problem. I hope someone will find a solution.
  • We can't reproduce this, but we think we know what's going on and should have a fix soon.
  • Great thanks it would be great if you could let me know how to fix this as soon as possible. How long do you think it would take?
  • @hamsinibijlani @olesol The fix is now available in the Zotero Beta.
  • @hamsinibijlani Great! I have tested the beta on a Mac user and it has solved the problem. Thanks for fixing it so quickly.
  • @adomasven Thanks for that! I downloaded the beta and deleted the old version however it is still saying "word could not communicate with Zotero" when i try using it. I'm not sure if this is because the older version has not been deleted properly? When i check the add-ins in word the Zotero one seems to be the same as before.
  • Could you provide another Debug ID for Zotero startup from the beta version?
  • This is the debug ID: D1043523657
  • If you go into Tools -> Add-ons do you see Word and LibreOffice extensions listed? Are they enabled? If you go into Zotero Preferences -> Cite -> Word Processors do you see entries for those extensions? What happens if you try to reinstall the Word extension?
  • The extensions for Word and Libre office are enabled under Add-ons however when i go to Preferences -> Cite -> Word Processors the only thing i can see is the option to enable "use classic Add Citation dialog"
  • Did you move the Zotero.app file from the downloaded disk image to your Applications folder?
  • These are rather vague for troubleshooting steps, but could you restart Zotero a few times and check if sections for Word and LibreOffice plugins appear under Preferences -> Cite -> Word Processors? If not, could you create a new user account on the computer and test to see if it works correctly there?
Sign In or Register to comment.