Wiley InterScience broken

Wiley InterScience translator seems to be broken, nothing is imported after clicking the usual button (using Zotero 1.0.10 in french)
An example: http://www3.interscience.wiley.com/journal/122522740/abstract

I reported the problem as tracker ID 262059972.

What should I do?

  • edited July 31, 2009
    this still works for me on 2.0b - it just takes a long time.
    Have you tried the standard workaround? Download citation --> Endnote?
    That should work for you.
  • Thanks for your answer. I forgot to precise that I have a small popup box on the bottom right of the browser informing me of the import failure.

    Could Not Save Item
    An error occurred while saving this item. Check < for more information.
  • OK - that's different of course.
    The workaround described above should still work.
    With my settings I can't replicate the error, so you'll have to wait for someone else.
    Another source of translator errors are frequently incompatible Firefox extensions.
  • Thanks again. EndNote-type import worked (just needed to manually add the PDF, which was better than copying the 21 author names)

    I tried disabling all my extensions (except zotero of course) and I still have the same error. However, on a clean Firefox profile, the import worked correctly.

    I followed debug_output to get a debug output, but it is too long to be included in a message (forum says “Some problems were encountered comments is 40150 characters too long.”), and it is not really meaningful to me.

    Maybe it is related to my database? In zotero's preferences, when I check the database integrity, it says that errors were found (not precising which or what to do to correct them).

    Thanks again for your precious help!

  • Calimo: Do you have "Accept third-party cookies" disabled in the Privacy pane of the Firefox 3.5 preferences? I get the error you're getting with that disabled.

  • edited August 2, 2009
    I've also just updated the Wiley translator in the repository to save extended characters correctly when saving via the address bar. Update from the General pane of the Zotero prefs to get the new version immediately.
  • Hello Dan,

    You were right, I had third party cookies disabled. Now I'm able to import from Wiley into Zotero :-)

  • I am using Firefox 3.0.6 with Zotero 2.0b6.5 and I seem to be having an issue with the Wiley InterScience translator: for papers with multiple authors, only the first author gets the name saved appropriately divided into last and first name(s) - all subsequent authors get the entire name saved as last name.
  • I've been having a problem with Wiley today, in this case with onlinelibrary.wiley.com (eg: http://onlinelibrary.wiley.com/doi/10.1111/j.1548-1433.2010.01244.x/full). Getting 'could not download document, check known translator issues' message. Also it seems to want to import the citation for an article as a folder, not as an individual article.

  • edited September 3, 2010
    Same problem here. If you click on Zotero's "Actions" button and then create an error report, you can see this:

    [JavaScript Error: "DOI Translator: could not find DOI" {file: "file:///<blabla>/zotero/translators/DOI.js" line: 0}]

    And indeed the DOI doesn't exist:

    It looks like a journal specific issue, as articles in other journals in wiley are correctly imported (although they are detected as lists). I think wiley broke the DOI system of this journal (even in past issues), and that's why it can't be imported. Give them a few days to fix their DOIs.
  • wiley interscience currently doesn't work, so the DOI translator takes over.
    That one is less reliable.
  • Wiley recently changed their website for all journals - which probably requires a rewriting of the relevant translators. This is not something I personally know how to do.

    For the journals that I have accessed there since the change, I have observed:
    - the pdf is no longer automatically saved
    - the page numbers are often missing (new structure of meta-data from wiley?)
    - journal abbreviation sometimes correct - sometimes full journal name instead.
  • syregnask: As noted above, since the site change Zotero is using the DOI translator on Wiley, and the DOI translator is more limited.


    Closing this thread.
This discussion has been closed.