sorting still not working, with 5.0.82

Sorting on the creator column still leaves out all items with an editor rather than author. Can this be sorted soon? Otherwise, impossible to create bibliographies. Thanks
  • Been having this problem too!
  • Fixed in the latest Zotero beta — thanks. The fix will be included in Zotero 5.0.83.
  • edited February 3, 2020
    I am on 5.0.83-beta.5+86a5c46b1 and this beta version still does not include editors when sorting on the creator column, that is they come at the end in a seemingly random order after the authors have been sorted alphabetically.
  • It's working here. Can you toggle sorting for the column and check again, and provide a Report ID if it's still not working for you?
  • I have toggled sorting for the creator column several times, pressed home and end to check both ways, but the sorting is still not working as expected. The report ID is: 1324173311
    The locale is set to English if that is relevant.
  • @ednawalter, @ljmcoleman: Is it working for you in the beta?
  • 5.0.83 just auto-installed and now I'm having the problem haraldaa describes. Authors in order, then everything else whether it has an editor or not in seemingly random order. Here's my report ID: 724639552. Thanks.
  • Correction, NOT random order. I just figured out the pattern. It lists everything in date order from oldest to newest. It then lists in alphabetical order anything left (i.e. no date entered).
  • @buchberger: Can you take a screenshot that shows what you're describing and either upload it somewhere and provide a link or email it to with a link to this thread?
  • @buchberger: Can you provide a Debug ID for Zotero startup, using the "Restart with Logging Enabled…" option?
  • Sure. D1836678161
  • If someone experiencing this wouldn't mind uploading their database to the DB Repair Tool and posting the Upload ID here, that would be very helpful. You can ignore the download links the tool provides, but the Upload ID would let us run some tests on the database to see what's happening.

    (A smaller version of the database with just a few items would be fine. To do that, temporarily unlink your Zotero from syncing in the Sync pane of the preferences, close Zotero, move the Zotero data directory to a safe location, create a new empty "Zotero" folder in its place, and copy the original zotero.sqlite file there. Then you can start Zotero and delete items in that copy of the database until just a few items that demonstrate the problem remain, empty the trash, close Zotero, and upload that version to the repair tool. After you've done that, you can delete that directory, move your main Zotero data directory back into place, and re-enable syncing.)
  • I have done what you asked for. My Upload ID is 5e569e0a1f5ad.
  • Thanks, @haraldaa — that's exactly what we needed.

    This was still failing for items with more than a single editor, which is why I couldn't reproduce this — I was only testing with a single editor. Fixed now in the latest Zotero beta, and the fix will be included in 5.0.84 soon.
  • I can confirm that it is fixed in 5.0.84-beta.2+8170cf09d.
  • This is fixed now in Zotero 5.0.84.
  • Sorry I didn't see this sooner - was teaching all day yesterday. I just updated to .84 and can confirm it's fixed now. Thanks to both of you!
Sign In or Register to comment.