PaperShip sync suddenly stopped working — API access down?

edited January 20, 2020
Some 12 hours ago syncing stopped working on my iPhone as well as on the iPad. Please check.
The Zotero desktop app is fully operational, both the latest final and beta versions.

This is the message PaperShip would send to their support:

Error domain: AFNetworkingErrorDomain (-1011)
Error description: Expected status code in (200-299), got 400
Recovery suggestion: 'since' parameter must be provided

Failing URL:

Response: { URL: } { Status Code: 400, Headers {
Connection = (
"Content-Length" = (
"Content-Type" = (
"text/html; charset=UTF-8"
Date = (
"Mon, 20 Jan 2020 10:42:06 GMT"
Server = (
"Apache/2.4.39 (Amazon)"
"Zotero-API-Version" = (
"Zotero-Schema-Version" = (
} } (400)

Device model: iPhone
System name: iOS
System version: 13.3
PaperShip version: 3.8.5 (177)
API platform: Zotero
Zotero File Storage
  • This is a problem with Papership forming their API call incorrectly. You would need to contact them.

    (You missed redacting one instance of your key.)
  • Thanks for your reply.
    I haven’t redacted any instances of my key... Should I edit out the key in the OP?

    Sync stopped overnight without any update to the PaperShip app, so unless there was a timed change in it, a problem on the Zotero server side seems much more likely.
  • Interestingly, I can still use the PaperShip app to add & upload new papers, it just won’t sync back, therefore any newly added papers appear in the desktop app, but not in PaperShip. So it’s only downsync that appears faulty.
  • One of the forum admins must have redacted your key. You should edit your post to remove the third appearance of your key as well.

    Papership is not well-maintained anymore since it was bought by Elsevier, and its Zotero API calls have been out of date for some time. The issue here is that the call you give doesn’t have a “since” argument, which is required. If you try the call you posted, but we’d &since=1 to the end, it works. It’s possible that syncing from Papership might work sporadically, but it seems to be very unreliable based on user reports here. As I say, this is a problem with Papership that they need to fix.
  • I've been using PaperShip with Zotero for ~3,5 years now. I've had more issues with 3rd party WebDAV servers than with the iOS app itself. Until yesterday evening it had worked just fine and that means dozens of syncs daily. Minor issues were fixed and layout was updated a few months ago, so the app is up-to-date and operational. If it doesn't have a "since" argument now, it surely hadn't had until yesterday. I can of course submit the above debug info to PaperShip, but as the app hasn't changed very recently, and sync suddenly stopped working on both my iOS devices, chances are much higher that it's a change on the Zotero server side.
  • Sorry, this was a bug introduced on the server side. since=0 should be allowed. Fixed now.
  • Thanks for the quick follow-up! It’s indeed working as usual now.
  • I'm still not able to get Papership to synch with articles I've added to the desktop version - nothing has synched since the 21st. I'm not techie enough to follow the conversation above - any advice though?
  • Trenapaulus, Papership sync issues persist and are unlikely to be fixed any time soon.

    The Zotero iOS app is now out as a beta (invite-only, but you can request an invite on the website), and I can confirm the sync is reliable, although the annotation tools are significantly more limited than Papership.
Sign In or Register to comment.