Add-In keeps crashing in libreoffice ID: 2101911817

Hey community,
I run libreoffice and zotero on manjaro linux.
Could use some advice with my zotero ad-in here.
It seems to me like LO is rejecting the ad-in over and over. Delete LO-user-profile and re-install the addin helps for a short time. But the next day it crashes again.
I tried re-installing the adin without removing the user-profile i get an error (ID in Title).
I would appreciate your ideas. Thanks in advance :)
  • What version of LibreOffice?
  • Version: 6.2.8.2
  • What Java version?

    @adomasven might have an idea, but this really sounds like a problem in LibreOffice, so beyond clearing the LO user profile or trying 6.3.4 I'm not sure what to suggest.
  • openjdk version "1.8.0_232"
    OpenJDK Runtime Environment (build 1.8.0_232-b09)
    OpenJDK 64-Bit Server VM (build 25.232-b09, mixed mode)
  • @adomasven The only instruction to get it running again is to remove the LO user profile. This is just not a permanent solution. The problem reappears after a short time.
    Java IRE is installed, selected and up-to-date.
    I would like to avoid using LO fresh. I am not really a power user.
  • When LO starts rejecting the plugin could you try manual plugin installation via LibreOffice extension manager (or just double-click the extension .oxt file) and paste the error you get here?
  • I'm giving LO fresh a shot. We'll see how it looks tomorrow.
    With LO still I got the error
    "Add extension(s): "DIRECTORY"/Zotero_LibreOffice_Integration.oxt does not exist".
    As suggested in the troubleshooting guide I removed the profile.
  • Is that actually the error message as you see it? That would strongly point to either a LibreOffice issue or something in your system configuration (perhaps something that changes the user profile folder).
  • edited 14 days ago
    Yeah, as far as I can remember, that's the message. LO-still is permanently frozen after this message appears.
  • Okay, I'm running into the same problem with LO-fresh v6.3.4.
  • I think you'll have to seek out help from the LO community. This isn't strictly a Zotero problem and we have not had any users run into something similar, so we cannot point you to anything beyond what we already have in terms of troubleshooting.
  • All right, well, thanks anyway for trying :)
  • Hey, the LO community could not help me so far.
    I am helpless and I am in fear to not find a solution. I appreciate that there are alternatives to Citavi and MO. Especially that you guys take the time and effort to make it available to the world.
    I have the need to do good work on my bachelor thesis. That puts me under pressure.
    The problem seems to have been around for a while and can only be solved by working together. Zotero and LO are both really strong when the applications fit well together.
    That would be my wish to you as a user :)
Sign In or Register to comment.