Errors when attempting to add citations to a Word doc on Mac

Like another user in a similar thread, I'm getting an error message when I attempt to add a citation to my word doc. The message is: "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

I'm using Word version 16.32 and Zotero version 5.0.80. I updated both today, and reinstalled the Zotero plug-in after updating. (I had the problem both before and after updating.)

I have deleted my entire word document so that it is now down to a single sentence. ("This is a test.") There is no bibliography.

I have taken all trouble-shooting steps, including changing the format for the bibliography. By default, I use IEEE (with URL).

If I create a new file with one sentence, inserting the citation works fine. (Even then the bibliography won't build -- a similar error message.) So apparently there is something corrupt in my original file, but what?

I have used option-F9, so I can see hidden text, but there is nothing but { ADDIN ZOTERO_TEMP } at the spot where I am trying to add the citation.

In an earlier version of my doc, I successfully added citations and built the bibliography.
  • Here's the report ID: 659184924
  • I have deleted my entire word document so that it is now down to a single sentence. ("This is a test.")
    And what? And you still can't insert a citation? And if you show field codes, you still only see "This is a test." with no fields?
  • The entire document before attempting to add a citation looks like this:
    "This is a test."

    After attempting to add a citation, it becomes:
    "This is a test. { ADDIN ZOTERO_TEMP }" (if I show hidden text)
    "This is a test. [1]" (if I do not show hidden text)

    This document was originally >50 pages. But as recommended in the troubleshooting notes, I cut it down to isolate the problem.
  • But a new document with the same sentence that you create from scratch works? If so, can you send the broken one-sentence document to with a link to this thread?
  • That's correct. I've emailed the file as requested. Thank you!
  • edited January 5, 2020
    We didn't receive a file. If there's nothing private it in, you can also just upload it somewhere (e.g., Dropbox) and provide a link here.
  • I’ve corrected a typo in the email address and resent. Please let me know if you’ve got it.
  • This might be obvious, but have you tried restarting your Mac? Also, can you insert multiple citations in a new document? Does Zotero properly number them, for, e.g. the IEEE citation style? How about if you use the Chicago author-date style?
  • Yes I’ve rebooted. And the document that I sent you had a hundred or so refrerences, but inserting new ones frequently, but not always, gave error messages. That led to my paring it down to isolate the problem. Did you receive my file?

    One early symptom was that a citation insertion could fail on the first attempt, but a second attempt at the same citation would work fine.
  • In answer to adomasven's other questions:
    Also, can you insert multiple citations in a new document?

    Does Zotero properly number them, for, e.g. the IEEE citation style?
    Yes. And the bibliography is correctly produced. (My earlier comment about a problem with the bibliography in the new document turned out to be due to an error on my part -- I was showing hidden text, which prevents the bibliography from displaying properly. After hiding the hidden text, the bibliography is fine.)

    How about if you use the Chicago author-date style?
    Yes, the bibliography looks fine, though this style does not produce numbers.
  • We got the file and the corruption is obvious, but how it got that way is not. The citation text seems to be updated, but the underlying codes not, as you yourself pointed out above. Your Report ID above indicates the plugin failing somewhat randomly when performing citation commands in Word.

    The only outlier right now is that it works well in new documents, but in the existing document it fails even if you remove everything, indicating perhaps a corruption within the doc file itself. Have you tried step 4 in the troubleshooting instructions? Did that have no effect? What if you copy the "empty" contents (by pressing Command-A to select all and then copying that) of the broken document to a new one?
  • Thanks. Cutting and pasting the text to a new doc works in the sense that I can insert citations and build a bibliography in the new doc.

    On the other hand, even though the citation is successfully inserted, I still get an error message from Zotero. The only way to tell whether the insertion was successful is to look at the hidden text, which is awkward, especially since my full document is dense with citations.

    Why do I get an error message even though the insertion works? It would be great to get an error message only with a real error.
  • Do you mean you get an error message from Zotero every time you insert? Is this only true for the document you are working on or also in a completely new document? Are citations sometimes inserted correctly (based on the field codes) even after receiving the error?
  • In the document that I created by cutting and pasting my sentence ("This is a test.") from the corrupt file, I get an error message when inserting a citation, even though the citation looks fine, and the bibliography is successful.

    My tests are not exhaustive, but it may only happen when the hidden text is being displayed.
Sign In or Register to comment.