[CSL STYLE ERROR: reference with no printed form.].

edited December 29, 2019
I am pasting here the exported citation which results in the error I have posted in the Discussion Title. This reference appears in the footnote directly preceding the error code. How can I continue using this reference if this error code appears whenever I select it in the Word "picker"? Your help is most appreciated.

<bib:Legislation rdf:about="#item_2510">
<link:link rdf:resource="#item_2509"/>
<dc:title>2017 Legis. Bill Hist. US H.B. 620</dc:title>
<z:jurisdiction>002usUnited States|US</z:jurisdiction>
<z:Attachment rdf:about="#item_2509">
<dc:title>2017 - 2017 Legis. Bill Hist. US H.B. 620.pdf</dc:title>
  • You get that error when the citation style is not set up to print anything for an item type.
    Which style are you using?
  • In Word, I selected Zotero>Document Preferences>Citation Style>JM Indigo Book (law reviews) and I have now been able to have the citation appear in the footnote in that Style (I think). However, because it has been cited before, it should read Id. So, I type Ibid in the Picker window (because I read that might work in the Forum), but it does not appear as an Id. How do I get that Id function to work again. Id cite format has worked in the past in that Citation Style.
  • This is in Juris-m, not Zotero, right? If so, @fbennett would be in a better position to help (and you should mention Juris-m when asking for help to avoid confusion)
  • Okay, I will post directly to @fbennett. The error code I mentioned pops up in Zotero not in Juris-M. Perhaps because that Citation Style is unique to Juris-M? When I switch to Juris-M, the citation style works (that is, no error message appears) but "ibid" or "id" does not. I do note that @fbennett has not posted since April 2019 in this Forum. Perhaps I might send an email to contact him?
  • fbennett last posted a comment 16 days ago. He will likely see the message here.
  • Thank you. BTW, when I click on @fbennett the "About" says
    Last Active
    yesterday at 7:17pm. But the posts I see there are from April. So, I am not seeing the more recent posts (can't be looking in the right place), which is why I sent the question to the JM support mailing list email address also, just now at your recommendation.
  • @lisaleine Hello! It's worth working this out on the Zotero forums here, in case others run into the same issue. I'll post a summary to the mailing lists once we've gotten to the bottom of it.

    Just to be sure, please check your Jurism version. The latest is 5.0.80m8. With the current client and style, I'm unable to reproduce that error. Does it happen in a simple document with just two identical references in separate footnotes?
  • @fbennett Thank you! Yes, I am using the latest version. The ibid is now working. I may have deleted the offending reference and then added it again. However, now I have a new JM question - when adding references to United States Regulations and Statutes there should not be an abbreviation to the U.S. in the parentheses according to the Blue Book. It should refer only to the year of enactment. So, Immigration and Naturalization Act, 8 U.S.C. ยง 1182(a)(4) (U.S. 2019) should be (2019). I've followed the Juris-M: United States Guide and just can't deselect the Jurisdiction - I think it is a "Required Field." How can I get the output to suppress the jurisdiction? I ask because I have tons of statutory references to deal with.
  • edited December 30, 2019
    I think you may have exposed a bug. I'm checking into it, but here's the back-story.

    You should be able to open a reference for editing in the document, click on the "Abbrevs" button in the widget there, get a popup with a search box at the top with a heading "Suppress Jurisdiction Names", type "United States" into the search box, and hit "Enter" to suppress the "U.S." jurisdiction element for all citations in the document.

    With the latest, I ran a quick check of that, and it's showing blank lines in the search-result listing, and then not recording any jurisdiction for suppression when a line is selected. That's obviously not right. I'm looking into it, and should have an answer and a solution in a little while.
  • I've tracked down the problem, and have a fix for it. I'll need to tidy up the changes before bundling them into a release, but the revised client should be ready by morning-time in the US.
  • The revised client is up. It should install itself automatically within 24 hours, or you can update immediately via Help -> Check for Updates. Let me know if you run into any further issues during your revision.
  • Thank you so much! I have updated and will report back.
  • When entering an item that is a "Case" in JM, I enter Maryland into the Court field to allow it to offer options. Then, I select Fourth Circuit l D. Maryland: District Court. Then I enter the date of the decision in the Date Decided field.

    The citation form I need (per the BB) is (D.Md. Oct. 14, 2019). Instead, the field in JM turns yellow, and outputs (U.S.D. Maryland: District Court, Fourth Circuit 2019).

    What should I do to get it to work?
  • On a quick test here with those steps, the Jurisdiction field updates automatically to "US|Fourth Circuit|D. Maryland", and the Court field to "District Court", without a yellow background (so the system is finding the court and jurisdiction ID).

    If you're on 5.0.80m9, one thought would be to stop the client, and start it up again, just to be sure everything is refreshed.

    If that doesn't help, what OS are you on (Mac, Windows, Linux)? I have all three here, and if I can replicate the problem, I can work out where the bug lies.
  • mac OS Catalina 10.15
    I will shut everything down and reload, and will report back.
  • Yes. Supra is working again. I shut down and reloaded - and supra began appearing in my Word document again. Thank you and Happy New Year!
  • Yay, that's good to hear. I seem to be on Mac OS 10.14.6 here, and it worked as well. For database grabs, https://courtlistener.com should be a reliable source, for cases available there.
Sign In or Register to comment.