Zotero Upgrade Error

I just upgraded to version 5.0 for Mac and got this error message

Error: Invalid field 'accessDate
From previous event:

It doesn´t seem to be the DB. Already checked if it was corrupted. Worked before perfectly.

Thanks in advance for any help
  • Solved. Erased library (previous backup) and reinstalled. Worked for me.
  • If you can still reproduce this with the original database, we'd like to troubleshoot this so we can help others who are affected.

    If you'd like to do that, can you upload the affected DB to the DB Repair Tool and provide the Upload ID here? You can ignore the download link that the tool provides — this is just to allow us to run some tests on the database file.
  • Original DB was very small and I just deleted it.
    Sorry, next time I´ll upload it. Now I know better.
    Thanks for the fast response.
  • @scimbollek: It seems like this can happen when upgrading directly from Zotero 4 to Zotero 5.0.79. We're working on a fix for others who are experiencing this. Sorry for the trouble.
  • @dstillman: My data directory was stored in the default location and not in any other folder.
    And once more, thanks for the interest.
  • Right, it wasn't that. (I deleted my earlier question.) It was upgrading directly from Zotero 4 (from 2017) to Zotero 5.0.79. We've fixed this in Zotero 5.0.80.

    We strongly recommend making sure Zotero stays up to date (which it should automatically, by default), both because of the regular improvements and bug fixes in new releases and also to avoid unexpected problems like this coming from very old versions (though we'll obviously try to avoid problems like this in the future).
Sign In or Register to comment.