Unable to connect due to certificate issues

Hi there;

I'm unable to get my Zotero to sync (AKA log into the application from the preferences) and am receiving an error whenever I try to create a citation for a doi or PMID (the magic wand), or even submit logs.

This problem started today, but the last time that I tried to use the magic wand, and it worked was a couple of months ago.

I'll Email my debug logs as soon as I'm done submitting this ticket.
  • edited 6 days ago
    Is this on a work computer with intercepted traffic? Did you previously use the certificate override steps? If so, you may need to follow those steps again with a current version of Firefox (and replace cert8.db with a cert9.db file).

    If that's not the case, you can send debug output to support@zotero.org with a link to this thread.
  • It is a work computer however I do not use firefox. I just uploaded the debug out via email.
  • It's not about using Firefox as your browser — Firefox is just the easiest way to generate a certificate override file (since Zotero is based on Firefox), which is necessary because your IT department is intercepting/monitoring your secure network connections using a "custom certificate authority".

    You (or your IT department) likely performed the certificate override steps in the past using an older version of Firefox, and you need to repeat the steps with a current version.
  • We attempted the certificate override steps and the issue was not resolved. Could you please provide a description regarding how traffic is being sent that is as technical and complicated as possible. Or could you upload the portion of the source code that contains the networking component for my company's Security Architect to review? Thank you!
  • The linked page hadn't yet been updated for 5.0.78. It has now, so try again. As of Zotero 5.0.78, the relevant Firefox files for a custom CA are cert9.db and key4.db (and secmod.db).

    (We haven't tested the custom CA steps with cert9.db/key4.db yet, but we don't have any reason to believe they won't work. Zotero's networking layer is just Firefox under the hood.)
Sign In or Register to comment.