How to suppress trailing punctuation in vanilla Zotero

Hi @adamsmith

I need to insert semicolons between citations in footnoted citations. Zotero automatically inserts a period after each citation. How can I override that period, insert a semicolon instead, and possibly even insert a signal (see, e.g.,) preceding subsequent citations.

Thank you!
  • (Please don't tag specific people for general questions. Various people here — both core developers and volunteers — answer questions.)
  • My apologies, I was trying to ask a question alluded to in a prior (now quite dated) discussion, and thought the tag would help to focus the question. But yes, absolutely, I appreciate the support.
  • Hi,

    I believe that I have found the answer to how to insert semicolons etc between citations - Classic View allows for modifications in the fields Prefix and Suffix. So, now I have a follow up question: how do you make Classic View the default?

    Thank you!
  • Someone else will have to comment on the recommended way to do what you're asking, but you don't need to use the classic view for prefix/suffix. Just click a citation's blue bubble in the citation dialog to access additional options.
  • In the support article noted above I found this - “ To permanently switch to the classic view check the “Use classic Add Citation view” checkbox in the Cite pane of Zotero preferences.”

    Thank you!
  • Right, but there's no reason to do that if you just want to customize the citations.
  • Yes, I see that now. Clicking on the blue bubble pops up options available in the Classic View - sparing you work and clicks to achieve the same result. Thank you!
  • (and yes, prefix/suffix is the best way to do this in most scenarios and the only easy way).
Sign In or Register to comment.