Error: "You must insert a citation before performing this operation" in all documents

Thanks as always for a great citation manager and a supportive and helpful community.

Brand new error on my system affecting both newly created documents and documents that have previously worked fine with Zotero.

Zotero 5.0.77
Word for Mac 16.31 (19111002)

Caveat: like any good bug, I can't pin down anything about the particular files it's affecting. Some old ones still work fine. Some new ones, too. But the problem is not limited to one or two documents, either, so I'm reporting it just in case.

Note: I have restarted both Zotero and Word. The issues persist.

I add citations, but every time I Refresh, I get the "You must insert a citation before performing this operation" error.

I became suspicious that citations are completely unrecognized because, for example, instead of

1. Pauer, “A New Order for Japanese Society,” 87.
2. Pauer, 86.

I get

1. Pauer, “A New Order for Japanese Society,” 87.
2. Pauer, “A New Order for Japanese Society,” 86.

Changing document preferences and adding new citations doesn't allow me to update the old ones.

Editing a citation erases the citation completely and gives me the "Zotero experienced an error updating your document." error. I am left with just "{Citation}0/0/00 0:00:00 AM" in the footnote.

Opening a new file and pasting paragraph by paragraph helps with some files, but not others. I can see neither rhyme nor reason.

For now, this is frustrating but not an emergency.
  • Are you saving the file as a .docx and not a .odt by any chance? .odt will lose the citations.
  • More info re: damnation's question:

    If parts of some documents work, you can try the Debugging Broken Documents steps (particulate the last step) to isolate the problematic parts.
  • I am left with just "{Citation}0/0/00 0:00:00 AM" in the footnote.
    Just guessing here, but the fact that you're left with part of a date field — assuming you didn't enter anything like that — might indicate that the Word fields were somehow corrupted by another program/format that only supports dates in Word fields and not other types of data.
  • Thank you all for replying.

    @damnation: docx only

    @danstillman: thank you for the links. 1) I have only ever created or saved the documents in question using Word. 2) I should have mentioned this, but my post comes after going through all the debugging steps. I am particularly confused by the fact that ALL citations are broken and I can't isolate any single problematic citation.

    I'll keep trying, though.
  • Update:

    I think it's possible that the error is somehow being introduced by text copied and pasted from PDFs. In taking notes, I often paste in plain-text-only text from PDFs (⇧⌥⌘V). I don't know how plain text could be a problem, but I've noticed that files seem to break after pasting. ALL citations break -- even those that were previously working -- I get the "You must insert a citation before performing this operation," and I have to start over from zero.

    FWIW, I'm using Skim 1.5.4 (120), the latest version.

    Does this help diagnose the problem?
  • If you can reproduce this in a new document, we'd certainly want to know the steps.
  • @danstillman, it just happened again with a brand-new document.

    Here's the process, as best I can tell:

    1. Create new document
    2. Type text
    3. Add citation (Zotero prompts for document properties, I select Chicago (note))
    4. Keep typing
    5. Paste plain text from Skim PDF reader
    6. Evil magic happens and all citations are borked

    I then pasted all of the text into a new document (Word-Word, no PDF involved), minus the citations. I added the same citations and everything works fine.

    So I tried one more thing. Instead of Skim, I tried pasting plain text from Adobe Acrobat (not Reader), and also from a few other sources such as Chrome, Preview, TextEdit, etc.

    No evil magic.

    So apparently there's a problem with the way that OSX is handling plain text from Skim, which is based on Apple's own PDF engine if I understand correctly. This is unfortunate, since it's the only PDF reader I use, and half the reason I have a Mac. And because (unlike here) the devs are about as helpful as blunt force head trauma. I'll see if I can get any comment from them about this, but I suspect that it may be related to a new feature in which you can save notes and highlights for each PDF as an external file that syncs with services such as Dropbox.
  • If you paste into TextEdit first and then copy again from there and paste into Word, does it still happen?
  • I have not been able to reproduce the error that way, or by pasting the text first into a browser omnibar, etc., that strips all attributes from the text. Of course, I'm using either ⇧⌥⌘V (or Control-⌘V and selecting plain text from the dialog) anyway, so this shouldn't make any difference.

    It's especially mysterious because, as you may know, you can't use Control-⌘V on plain text, only on formatted text. Nothing happens when you try to Control-⌘V plain text on Mac. So I know whether the system thinks the text is plain text. It does. And yet...

    For now, I have a workaround, and like I said, I'll contact the Skim devs and see what they think.
Sign In or Register to comment.