Has anybody decrypted Mendeley's library?

edited November 15, 2019
I am trying to move away from Mendeley, as many others.
I have a pretty big library, with many (~9000) PDFs, hundreds of them with annotations.

I have a clear idea of what I should do.
1) get hold of an unencrypted version of the database, since I'm running the latest version of Mendeley (1.19.5)
2) use menextract2pdf to export pdfs with annotations
3) use the Mendeley import feature of Zotero

I'm having some trouble with step 1.
All my PDFs are on Mendeley's cloud, so I tried installing version 1.18 and downloaded all the papers. This worked and I could perform steps 2 and 3.
Unfortunately I found out at the end that for some reason Mendeley did not download all of my PDFs, so many of them were missing.

Now I'm here to ask wether anybody managed to perform the decrypting procedure explained here https://eighty-twenty.org/2018/06/13/mendeley-encrypted-db
I have tried multiple times, with no luck, both with Ubuntu and macOS.
  • edited November 16, 2019
    We've never tried those steps, but where did you run into trouble?
  • Thanks for replying!
    I was able to follow the whole procedure, but I could never get the successful output "$1 = 0" from the rekey command. Sometimes I got "$1 = 8", but even doing the things written in the section "Update" I could never manage to succeed.
    Other times I also got different errors from the rekey command and one time it also got stuck... I've tried many times...
    This is on Ubuntu, on macOS I had less success overall!
  • I see this is an old thread, but for posterity the steps below should make it easy for you to import your otherwise encrypted Mendeley library into Zotero. I made the switch from Mendeley to Zotero because Mendeley no longer supports Mac OS X Catalina :-(

    1. In Mendeley navigate to My Library > All Documents
    2. Select All (Cntrl or Cmd + A)
    3. Right click your selection and choose Export
    4. Export your selection as a .bib file to a familiar folder
    5. In Zotero, import files from that familiar folder

    and your files should slowly populate your Zotero library ~

    Stay healthy!
  • Note that this will not actually import your full Mendeley database (e.g., notes, annotations, etc.). To import from Mendeley, the best procedure is this: https://Zotero.org/support/kB/mendeley_import
  • @sforward: As noted on the support page, while you can export to BibTeX as a last resort, you'll lose various parts of your Mendeley library that way (including folders), and you should only do that if you've tried all the other steps.
  • Mendeley has also added an API based export to Zotero feature in their latest development version that may be worth checking out. I don't know of anyone who has tested this with Zotero, so would be interested in any experiences
  • More than one year after my original post I finally found time to look at this issue again. It turns out that last year I was doing something very stupid.
    I write just to confirm to whoever might be intersted that the procedure to decrypt the database ( https://eighty-twenty.org/2018/06/13/mendeley-encrypted-db ) works correctly with Mendeley Desktop 1.19.4 on macOS Catalina. I was able to run menextract2pdf and run the Zotero native import function without problems.
Sign In or Register to comment.