Google docs - citations spontaneously unlinking

Hi! I'm using Zotero with google docs. Unfortunately it seems like my citations are unlinking without me intending to do this. Cittions I've added in previously seem to have reverted to plain text (ie, if I click on them in text there is no option to "Edit with Zotero" and the citations become static and mismatched to the bibliography). It seems like this is what would happen had I unlinked the citations, however I haven't intentionally done this.

Any ideas of why this might be happening?

Thanks in advance!
  • Have you by any chance copied those parts of the text somewhere else (e.g., to Word) and pasted them back into the document? Or copied and pasted them around in this document? (The latter shouldn't be a problem, but just in case.)
  • edited November 14, 2019
    No, I'm confident I haven't copied and pasted them elsewhere and then back into the document. I might have copied and pasted some sections within the document, but I don't think I've done it to all sections that have been affected, so I don't think that is the answer, But I'll pay attention to my copying and pasting and see what happens.

  • I assume this isn't the case but you should also make sure you're not editing a Word document stored in Google Drive rather than a proper Google Doc.
  • Yes, it's definitely a Google Doc, not Word. But thank you - I do appreciate your suggestions and your thought on this problem.

    I haven't had the citations de-link since I posted my original comment. I am trying to keep close track of actions I take with the document to try to pinpoint what might be prompting the de-linking should it happen again.
  • I am having this same problem, repeatedly, and it's unrelated to copy/pasting. When I close the google doc and re-open a few days later, many of the citations are now unlinked. Although oddly, it's not all of them? I haven't figured out any particular pattern of which ones are unlinked though.
  • @kdybala we are not aware of any other problems that could cause citations to unlink. You can always look at and restore versions of the document from the revision history to try and track down what change exactly lead to their unlinking.
  • Hi, this unlinking problem is happening in a very long document (>40 pages) with many citations (>60 citations). I am able to reproduce the problem in Chrome with the Zotero Connector Add-On installed, while Zotero Desktop is running.

    The unlinking happens if I change document preferences so that citations are not automatically updated. I have submitted a log with Debug ID D430899046. If you need anything else please let me know at
  • @mihussai The citations in your document are unlinked (the underlying field codes Zotero stores to identify the items are gone from the document) and triggering a Zotero action (any action will have the same result) is making Zotero notice that. The primary reason for citations becoming unlinked is somebody copying/pasting text in the document without the Zotero Connector installed in their browser. Your best bet for restoring citations is attempting to work with an earlier version of the document from the Google Docs version history.
  • @adomasven Thanks very much for this helpful information. I will ask all my collaborators to install the Zotero Connector in their browsers. In the longer term, it would be really great if any fixes could be made to the Zotero Connector to make it a little more resilient to unlinking. Many thanks to you and all the Zotero developers for supporting academic collaboration.
  • A bug has recently surfaced (possibly due to some changes by Google Docs) which had broken copy-pasting citations, but since has been fixed and we know of no bugs that would prevent citations from copying properly as long as the Zotero Connector is installed on the browser where the document is being edited.
  • Within the last month, I am constantly getting Show Unlinked Citations in the top RHCorner of Google Docs operating in Google Chrome browser. I have always had the connector installed; I insert citations from the Zotero Desktop (latest vers 5.0.89) always open in any session. I am copying/pasting sections with inserted Zotero citations within the same document. Also I am also "making a copy" of the document, giving it a new name (e.g. Draft to FINAL version for keeping track). The unlinking is occurring so much it is making the usage of Zotero no longer a benefit. It is very time consuming to relink only to find more affected. I never had this problem before. Ever, even doing the same exact thing. Copy/paste are essential to drafting, rewrites, etc. New Google Docs bug seems to have occurred and Zotero has not caught up? Thanks for the assistance in advance.
  • edited August 24, 2020
    @adomasven will need to say more about the underlying problem, but note that the feature that detects unlinked citations is new, so it's not necessarily the case that whatever problem you're facing is new.

    The best chance of fixing this would be if you could figure out exactly what step it is you're taking that's causing it to happen. Version history can probably help you figure that out.

    Just to be sure, you're not sharing the document with anyone else?
  • @dstillman and @adomasven Thank you, but it is definitely a collaborative doc with another person. However, I didn't have this in other collaborative docs before. Yes, I did realize the feature detecting unlinked citations.
  • And are you positive your collaborator has the Zotero connector installed in all their browsers when they work with the doc?
  • Yes, and this is happening between work sessions that only I am in the document, logged in as same user.
  • That may be a misunderstanding. If someone else makes an edit to the document without the Connector, they wouldn't get a warning, and you wouldn't get a warning right away. You'd only get a warning the next time you did something that caused Zotero to refresh the document.

    Again, you should be able to determine this definitely from the version history. You'll need to revert to a particular point and then click Refresh in the plugin to see if it triggers the warning.
  • Also, I am noting in one single session today, no new document, etc., that if the citation is updated post "downloading / saving to zotero" from the browser connector and insertion into the google doc, it will unlink. For example, I download a blog, but the date is not downloaded. I insert it into google doc before noticing such an issue. Then I notice it, return to the Zotero desktop to fix the record. I then "update"/edit the citation in google doc. It seems fine. But within a little while it is in red text and is noted as an unlinked citation.
  • That's almost certainly not happening. Simply editing an item in Zotero would not unlink it from the document — there's just nothing even remotely related happening there.
    I then "update"/edit the citation in google doc.
    What do you mean by this? All you need to do is press Refresh. And if the warning doesn't appear then, the problem had nothing to do with the edit.

    Again, there's really no need to speculate here. This is almost certainly going to be some sort of change you make in Google Docs, not in Zotero. You can figure that out from the version history.
  • I agree with you, but seeing it. By update/edit, I mean I click the inserted citation, and the Zotero "window" comes up that says "Edit with Zotero", which I click on it. Thank you for your comments. I can only describe what I am doing and documenting it for assistance.
  • I agree with you, but seeing it.
    If we say the thing you think is happening almost certainly isn't really happening, insisting that it is isn't a useful response. We know what's in the realm of likely possibilities here. The way to get this fixed is to tell us the exact steps to reliably reproduce it in a new document. Even if editing metadata somehow was causing this — which would be a major, bizarre bug that other people would likely be reporting — we would still need exact steps to reliably reproduce it.

    Since no one else is reporting this, and we can't reproduce it, that's the only way this problem, whatever it is, will get fixed.
    By update/edit, I mean I click the inserted citation, and the Zotero "window" comes up that says "Edit with Zotero", which I click on it.
    And then what? And why? While nothing in there should cause anything to become unlinked, that's not something you should be doing if you just made a change to metadata in Zotero.

    For what it's worth, I'm currently getting a "Selected field […] not returned from Docs backend" error the second time I click "Edit with Zotero" on a just-inserted citation in a document. Reloading the Google Docs page causes that to work again for existing citations. I can reproduce that several versions of the Connector back, so it may be a change on the Google Docs side. We'll investigate, but again, you shouldn't need to use that if you simply edited metadata in Zotero.
  • I'm currently getting a "Selected field […] not returned from Docs backend" error the second time I click "Edit with Zotero" on a just-inserted citation in a document
    We've fixed this in the latest Zotero Connector beta for Firefox.
  • I'm experiencing widespread spontaneous (but not 100%) un-linking as well. It's quite frustrating. This is a long document 12,000 words with 100+ citations I'll add some cites in gdocs vis the zotero tab in chrome, go on to other parts of the document, and come back. Post refresh, some of the new cites are unlinked.

    Is the upshot of this that ALL individuals who have access to doc must have zotero connector installed, even if they are not editing citations?
  • Is the upshot of this that ALL individuals who have access to doc must have zotero connector installed, even if they are not editing citations?
    @jcdonner: Anyone making edits to the document should have the Connector installed. Otherwise something as simple as dragging or cutting and pasting some text that contains a citation to another place in the document will cause it to be unlinked.

    We're not aware of any situations where this happens with the Zotero Connector installed and enabled. If you can reproduce that somehow, we'd certainly want to know.
  • Thanks @dstillman -- not good, but good to know. I'll keep an eye on who touches the document, and who among them has the connector installed.
  • Hi. I have been experiencing the same issue-- what appears to be spontaneous unlinking coupled with recurring stalled "Updating" notifications. My document is not shared with anyone. I *think* it might in part be related to copying and pasting within a document and having more than one Google account? But, I am not sure about the "Updating" issue. I use Chrome.

    I am happy to do whatever you advise to isolate the problem, but I might need directions on how to best accomplish this. Thank you!
  • @mstyang: If you're able to reproduce the unlinking, we'd want to see a Debug ID from the Zotero Connector for it happening, as well as the exact steps to get it to happen.

    Having multiple Google accounts doesn't matter, but when prompted for authorization by the plugin you need to choose the account associated with the document you're editing. (But if you chose another I believe it would give you an error immediately, not just not work later on.)
  • @dstillman Thank you! I have done my best to recreate the issue. I will try to describe what I think happened, and I also submitted a debug report: D728538989

    I have two Google Drive accounts. I was working in a document in one Google Drive Account. I copied and pasted a citation within a document. I quit Zotero. I then went to work in a document in my other Google Drive account. I returned to the first document in my primary account and tried to insert a new Zotero citation, as soon as I tried to insert and it went to give me the notification that I needed to open Zotero (because I had closed it) it appeared to break existing links.

    My only uncertainty is if I should just try this without going into my other Google account b/c maybe the issue is more related to quitting and restarting Zotero?

    Let me know if this helps narrow down the issue. I definitely always choose the right account when I am asked that question as I really only do footnote type of work in my primary account.
  • If you see the notification about broken links it means that the very previous action had already broken it. That would have been copying the citations. We haven't tested working with different google docs accounts at the same time, but I suspect that some things, like copying citations between docs owned by different accounts might indeed not work correctly. Copying withing a document should work as long as that's the document that you have Zotero authenticated for citing.
  • Thank you @adomasven

    I am not copying between documents just within the same document.

    I am just going to documents in my other Google Drive and working (just typing, not even working with Zotero), and then returning to my primary Google Drive

    I am not even sure if copying is the action that is creating the broken link. It may be related to quitting and restarting Zotero.

  • Restarting Zotero has no effect on the citation links in Google Documents. Only editing the documents would. Are you editing with a browser that has the Zotero Connector installed?
Sign In or Register to comment.