Zotero Connector not working with Google Docs in Firefox

edited 5 days ago
Report ID: 25443479

I cannot manage citations within Google Docs using Firefox. When I click "Zotero > add/edit citation..." in the Google Docs menu the following happens:
- a message saying "Zotero is updating your document. Please wait..." is displayed within the Google Doc
- the Zotero red text bar briefly flashes onto the screen
- a new Firefox window opens and starts the authorisation process (despite Zotero already being authorised)
- the Zotero red text bar and new Firefox window close
- an error message is displayed in the original Firefox window: "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

I have tried:
1. Firefox and Zotero are updated to the latest versions
2. Removing other Google Doc add-ons
3. Restarting my computer, Firefox and Zotero
4. Purging the Zotero.org library (it was 95% full and a large .pdf was creating an error message)
5. Opening a blank Google Doc
6. Editing existing Google Docs that contain pre-existing Zotero citations

I am given the above error message whenever I try to use Zotero within Google Docs. However other aspects of Zotero Connection (eg. "Save to Zotero" for metadata scraping) work well.

  • Are you still having trouble? From your error report it looks like it could have been a temporary error. Some of your requests to Google were failing.

    If it's still happening, can you provide a Debug ID (different from a Report ID) from the Zotero Connector for an attempt?
    Purging the Zotero.org library (it was 95% full and a large .pdf was creating an error message)
    This would've been totally unrelated, by the way. (It's also not clear what exactly you did, but if you're referring to the Purge Storage button on the storage settings page, that almost certainly doesn't do what you think. That's for freeing up space for group libraries after disabling file syncing for My Library locally.)
  • Hi dstillman,

    The problem seems to have resolved over night. It must have been a temporary error. Thanks for getting back to me.

    Cheers
Sign In or Register to comment.