Field too long to sync

Hi, new to Zotero and I keep getting the following error message:

**The creator name “insert authors…” in one of your items is too long to sync. Shorten the field and sync again.

If you receive this message repeatedly for items saved from a particular site, you can report this issue in the Zotero Forums.**

I've been unable to sync any of my library with my online account. When I click show in library, the item displayed doesn't even have those authors! The articles are saved on my computer in RIS format from Ovid, then imported. They all just show the main author et al in the creator field. I have over 10,000 articles so could really do with it syncing, please help!
  • When I click show in library, the item displayed doesn't even have those authors!
    Can you take a screenshot of the info pane for the item that's selected when you click Show in Library, upload it somewhere (e.g., Dropbox), and provide a link here?
  • Right, so the value it lists exists in that last creator line (Editor), in the first name field. (I would guess that all 359 contributors from the paper are included there.)
  • edited 5 days ago
    And note that, if you can reproduce this from a fresh import using the Save to Zotero button on Ovid, we'd want to know exactly where you're saving from so that we can try to fix it in the translator.

    If it's only happening when you export manually to RIS first, that'd be worth knowing too, but it likely points to a problem with the RIS export. (In site-specific translators we can correct data errors in the metadata served by the site, but that's less of an option in a generic file import.)
  • Hi,

    Thanks! Hoping there aren't too many articles affected by that issue. It will be painstaking having to go through them all to resolve it if not. It is only happening when I export manually to RIS first. Every time I try to import using the Save to Zotero button I just get an error message so I don't seem able to do it that way. I took a screenshot of the error I got today when trying to use the button to import directly from CINAHL.

    https://www.dropbox.com/s/9otavmmusuwv5k1/2019-11-09 (2).png?dl=0
  • edited 4 days ago
    Every time I try to import using the Save to Zotero button I just get an error message so I don't seem able to do it that way.
    Do you mean that it's not working anywhere, or that it's not working on EBSCOhost specifically?

    If anywhere — including, say, this forum page —  see Troubleshooting Translator Errors. If it's failing on EBSCOhost specifically, can you provide a Debug ID from the Zotero Connector for a save attempt that fails?

    (If you're saving many items at once, exporting to RIS first would be fine, but in general you always want to use the Save to Zotero button.)
Sign In or Register to comment.