Zotero Connector for Chrome unable to communicate with the Zotero desktop application

All of a sudden my Zotero connector for Chrome stops working, and I am unable to add directly to my library automatically with the Zotero app open. I have tried the suggestions on https://www.zotero.org/support/kb/connector_zotero_unavailable to no avail. I verified that "Zotero Connector Server is Available" by pinging I have disabled a number of Chrome extensions including AdBlock, and uninstalled Malwarebytes which I had recently installed. But nothing works. In short, the Zotero desktop app is open, the Zotero connector is installed and enabled, and port 23119 is active, but " Zotero Connector was unable to communicate with the Zotero desktop application."
  • 1) Restart Chrome.
    2) Restart your computer.
    3) Temporarily disable all other installed extensions, not just ones you think might interfere.
  • Thanks for the suggestion. But Zotero connector is still not working after all addons have been disabled.
  • Can you provide a Debug ID from the connector for loading a page — this forum page will do — and clicking the Save to Zotero button?
  • Following the instructions on "debug output," I opened chrome://extensions/, but did not find an "options" link underneath "Zotero Connector." Instead the links are for"Details," "Remove", and "Errors." When I clicked on "Details," I do get a page that may be the Preferences page referred to in "debug output," but there is no "Advanced tab." Instead of a checkbox for "Enable logging," there is an "Collect errors" option that can be turned on. However, I do not see anything like "Submit Debug Report."

    Clicking on "Errors" opens a page with list of errors encountered, but there is also no submit button. Might this page be relevant to pinpointing the problem?

    I also went to the Zotero Standalone app and clicked on "Report Errors" and "Submit Bug Report." The generated Report ID is 2028162584. Is this relevant?
  • When I clicked on "Details," I do get a page that may be the Preferences page referred to in "debug output," but there is no "Advanced tab."
    There's just an extra screen now. Click "Details" and then "Extension options". I've updated the instructions.
  • I clicked on "Details." I noticed that under the General Tab, "Zotero Status" states that Zotero is currently unavialble, even though pinging indicates that "Zotero Connector Server is Available".

    I went to the Advanced Tab and checked "Enable Logging" under "Debug Output Logging."

    After clcking on the Zotero button in an unsuccessful attempt to add a web page to my collection, I return to the Advanced Tab page and click on "Submit Output" button. I get this error message:

    An error occurred submitting your debug output.

    HTTP request to https://repo.zotero.org/repo/report?debug=1 rejected with status 0

    Please check your Internet connection ...

    However, my Internet connection seems to be working normally.
  • Yeah, so something is broken in your Chrome installation. If you've tried uninstalling and reinstalling the Zotero Connector and that didn't help, you can try creating a new Chrome profile. This isn't something we can do anything about — something within Chrome is preventing the extension from making network connections that even the browser itself can make.
  • I reinstalled Chrome. Then I reset Chrome, and reinstalled Zotero Connector. It worked on the first try. But after I reactivated just one addon (Print Friendly & PDF), not only did Zotero Connector stop working, the Zotero entry I just saved disappeared as well. I repeated the process of reinstalling Chrome, resetting it, and reinstalling Zotero Connector, but this time the Connector would not work. However, this time I was able to "Enable Logging" and get a debugging report, which is D72262475. Might this report provide some clue to what went wrong?
  • But after I reactivated just one addon (Print Friendly & PDF), not only did Zotero Connector stop working, the Zotero entry I just saved disappeared as well.
    I don't know what you mean by that, but I'm pretty sure this is some sort of misunderstanding. Items are saved to your database in the Zotero app, at which point they have nothing to do with the Zotero Connector. Even if something broke the Zotero Connector, that would have no effect on your Zotero database. It's possible you saved to your online library, though it would've prompted you to do so first.
    this time the Connector would not work
    Wouldn't work in what way? The debug output shows a successful connection between the Zotero Connector and Zotero:
    (3)(+0000000): HTTP POST

    (3)(+0000005): Connector: Method ping succeeded
  • I suspect that it must be because Zotero Connector is now saving to the online library rather than the local library. In much earlier attempts to get the connector to work I was prompted to reload the page in order to use the connector, and when I reloaded there was an option to save to the online library which I checked. How do I turn off this option so that I can save to my local library? Sorry that this debugging has taken so much of your time.
  • When it saves to the online library, it will say explicitly that it's saving to "zotero.org" in the save popup.

    That shouldn't be happening based on your debug output, though. As soon as the connector sees Zotero again, which it did in your debug output, it will stop saving to the online library and prompt you again if Zotero becomes unavailable.
  • After repeating the sequence of (1) reinstalling Chrome; (2) resetting Chrome; and (3) reinstalling Zotero Connector addon, this time the connector is working consistently. I am re-activating my addons one at a time, and will report if any is found to interfere with the functioning of the connector. Many thanks for your help on this pesky problem!
Sign In or Register to comment.