error when syncing: "spec is undefined"

Hi,

When trying to sync my library, I get the following error: "spec is undefined"

(ID: 2044699497)

Apparently, something is wrong with webdav sync (the latest attachments added to my webdav folder are dated yesterday; the ones I tried to add today, are only in my computer).

Oddly, when I try to open pdf attachments that are not in this particular computer (I sync between 2), I can access them.

What can I do?

Thanks,
JB
  • The proper error isn't displaying for that, and we'll be fixing that, but that error means that you specified a URL that includes a path that doesn't exist. Zotero will automatically create the 'zotero' at the end but it won't created additional folders above it.
  • edited 9 days ago
    Hi,

    Thanks for your quick answer.

    I checked pcloud (my WebDAV server) and everything seems to be in accordance with what you said: I have only one folder, named \zotero, with no folders above it.

    Also, in Preferences, the link to pcloud is the same as in the last months: (https://webdav.pcloud.com/zotero). It’s strange - until yesterday, everything was working fine.

    Last time I’ve tried to sync, I requested a debug report: D402500736. Could it be a network problem?

    Best regards,
    JB
  • edited 9 days ago
    (Sorry, I meant https://webdav.pcloud.com/, without “\zotero”, as is specified in the documentation section)
  • There's some server misconfiguration there. PROPFIND requests — a core part of WebDAV — are returning 404 for both /zotero and /:
    (3)(+0000160): HTTP PROPFIND https://********@webdav.pcloud.com/zotero/ succeeded with 404

    (3)(+0000000): <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /zotero/ was not found on this server.</p>
    <hr>
    <address>Apache/2.4.10 (Debian) Server at webdav.pcloud.com Port 443</address>
    </body></html>


    (3)(+0000000): HTTP PROPFIND "<propfind xmlns='DAV:'><prop><getcontentlength/></prop></propfind>" to https://********@webdav.pcloud.com/

    (3)(+0000162): HTTP PROPFIND https://********@webdav.pcloud.com/ succeeded with 404

    (3)(+0000004): File sync failed for library 1
  • I see. I can try to connect my work laptop (that’s where the error is) to my home network, tomorrow, and see if the same occurs. I didn’t wanted to try my home computer, because I edited and added some references at work and don’t want to have to do it all over again.

    Or by “server misconfiguration” you mean WebDAV server?
  • Yes, this is a problem with the WebDAV server.
  • Ok - then I hope it sorts out, or else I’ll probably have to migrate to another WebDAV...
    Thanks for your quick answers!
    Best regards,
    JB
  • Looks like whatever was causing the issue is gone - everything working fine now.
    JB
Sign In or Register to comment.