Web Library Beta: Cannot scroll on mobiles in collections list

When trying out the new web library beta -- which looks great! -- on my mobile resp. switch to that modus in my browser, then I cannot scroll anymore in the collections list. In the other panes scrolling seems to work.
  • There was a bug in a version before we made the beta publicly visible that had drag-and-drop still enabled on touch devices. That caused it to move collections into other collections when trying to scroll.

    I don't think it should be possible that you got that version, but you should make sure that hasn't happened with your collections.

    Otherwise we haven't been able to reproduce this. Could you give details on the mobile OS and browser versions?
  • I am using Firefox 69 (Windows, 64-Bit, testing mobile version Ctrl+Shift+M), Chrome 78 (Windows, 64-Bit, testing mobile version Ctrl+Shift+M) and my Firefox 68.1.1 (Android). Everywhere I see the same behavior: I can scroll on list of items and details page but not on a collection of items. Any idea?
  • Just to clarify, are you saying you can't scroll the list of collections, or the list of items inside a collection?

    I still haven't reproduced being unable to scroll at all on collections, but I have managed to find instances where I can't scroll all the way to the bottom (https://github.com/zotero/web-library/issues/290). I wouldn't think this is exactly the same unless you have just the right number of collections to make it not scroll at all.
  • I can't scroll when I am looking at my list of collections i.e. "My Library" resp. in a subcollection of it which itself has more subcollections than it can be displayed on one page.

    The linked issue sounds different. I have for example 22 subcollection in one of my main collection, but can only see 10 of them and the "Items" entry.
  • It is related to the browser(s). I just tried on my mobile phone the Samsung Browser and scrolling there works without any problems.
  • In Firefox I still see some error and warnings, see https://gist.github.com/zuphilip/dd2522d30abf83e99ea955103da3e238 and the last one is speaking about scrolling.
  • I've gone and tried in Windows now, and I still only get that first warning (which we have because Safari, IE, and Edge don't support the new CSP directives).

    The two blocked scripts I would guess are being injected by an add-on.

    It seems unlikely that an add-on would have this specific effect, but you could try temporarily disabling any add-ons to see if that changes anything.
Sign In or Register to comment.