Zotero not saving

When I click the folder icon in the browser bar and then choose the items I would like to save from the library catalog (WorldCat), and say "OK", Zotero asks again or gives an error message. Zotero is open.
  • After several tries, the dialog box sometimes pops up, but does not show the item being saved as it has always done before, but the item has been saved.
  • This problem did not just happen for me--I was teaching a Zotero workshop yesterday, it happened to the students also. I thought it was a temporary glitch but I teach another workshop today at 12:20 pm and I'm hoping it can be resolved.
  • See https://www.zotero.org/support/troubleshooting_translator_issues
    If the steps don't solve the issue, we need all the information in the last step.
  • thank you, I'm going through the steps
  • https://search.proquest.com/results/92906DF743164CDEPQ/1?accountid=4216

    Only the little selection boxes (for the yellow folder icon), no accompanying text beside them, but sometimes will save anyway when little boxes are checked.
    Error message sometimes says "Troubleshooting translator issues"

  • Working erratically--sometimes saves when choosing individual items, rather than several from the folder icon selection boxes
  • See Site Access Limits — ProQuest is one of the sites that blocks you if you try to save too much at once.

    Try the alternative approach there or save individual items.
  • edited October 17, 2019
    @StMarci: Also, please don't create new threads for the same issue. As the linked instructions say, "use your existing thread if you've already created one". I've moved your follow-up posts back here.
  • edited October 17, 2019
    Quoting your email here, since this is where support needs to happen:
    So, the same issues outlined in my thread happened at the workshop: When students tried to save a book from WorldCat or an article from ProQuest, they would click the Zotero capture icon (a yellow folder because we were looking at more than one item on a page) and instead of the Notification box appearing and saving the item, the selection box would reappear a second time. They would repeat selecting an item (or several) from the selection box, and although the name of the item being saved would not appear in the Notification box as it typically has in the past (only "Saving to My Library" would appear), Zotero would actually save the item(s) in their Zotero libraries.

    In Proquest, the selection box would appear with the little open boxes to place a check mark, but without any text (the names of the items) beside the little boxes. But if you checked some of the little boxes anyway, Zotero would save them in My Library, and the names of the articles and the PDF icon would appear under "Saving to My Library".
    As I say above, the most likely explanation is that ProQuest is blocking your IP address (which, depending on the network, could affect all the students) for making too many requests at once. Unfortunately sites can do this in different and unpredictable ways, so it's usually not possible for us to show a clearer error message.

    For WorldCat, we would want an example URL, but it could be the same issue.
  • (I think ProQuest is a real translator issue -- the lack of titles in the select dialog definitely is)
  • Thanks for your help. I do not think it is an issue of ProQuest blocking the IP address for making too many requests at once, because it happen when I am probably the only person at this entire university asking for Zotero to save something, and even when I had a class, it consisted of 4 students, and only 1 or 2 were in ProQuest at the same time.

    Here is an example URL from WorldCat: https://stfrancisuniversity.on.worldcat.org/search?queryString=gerrymander

    This is what happens, not only to me, but to all the students:

    Student goes to WorldCat, runs a search, clicks the yellow folder icon. The Zotero Item Selector box comes up as it should. Student makes one or two selections but then the Item Selector box pops up again and student makes selections a second time. Then the Saving Notification box in upper left DOES pop up and says it is "Saving to...(My Library)" but it doesn't say WHAT is being saved (like it typically has in the past). And indeed the item(s) have been saved.

    In ProQuest, the Zotero Item Selector box comes up totally blank (white) except for the little black boxes for the user to check off which items he or she wants Zotero to save, i.e. there are no titles beside the little black boxes. However, if the user checks some of the little black boxes anyway, the Notification DOES pop up immediately (no need to do it twice as in WorldCat) and DOES save the checked items AND lists the titles being saved. And indeed the item(s) have been saved.
  • edited October 18, 2019
    OK, the problem with empty titles in the item selector on ProQuest should now be fixed, thanks to adamsmith. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.

    That WorldCat page is working for me in Chrome. I load that page, click the folder icon, select the top two items, click OK, and they show up in the save popup and save correctly to Zotero. If that's not working for you, we'd want to see a Debug ID from the Zotero Connector for a save attempt that fails.
  • ProQuest is indeed fixed--no more empty titles--thank you adamsmith.

    However, WorldCat is still not working, rather continuing to do what I described above: Zotero does save, but only after the Selection box appears twice and items are selected twice, and then not saying which items are being saved.

  • That's from Zotero. We'd want a Debug ID from the Zotero Connector for the save attempt.
  • I was following the instructions to provide you with the Zotero Connector Debug report, and WorldCat worked properly this time. My heartfelt thanks dstillman!
  • We didn't change anything, though, so if you continue to have problems, let us know.
  • WorldCat problem continues--I need to check the Zotero Item Selector boxes twice (first time the box just disappears). Zotero notification box pops up and says "Saving to...(My Library)" but does not list the items being saved beneath that. The items are indeed saved though.
    Debug ID: 2117504049
  • I don't know if you changed anything or not, but I've tried WorldCat a couple times in the interim and it is working now...
  • We didn't change anything. When it wasn't working, you were getting a server error from WorldCat.
Sign In or Register to comment.