How to stop Zotero from automatically switching fonts on Mac

Zotero seems to now automatically switch fonts based on the retina/non-retina display. Dragging windows between the retina and non-ratina display changes the font automatically from the system default to Lucida. This is very annoying when using multiple displays. Does anyone know how to stop this behavior? and keep a consistent interface across monitors?
  • I am also having this Lucida problem. I don't know how to fix it but it is very hard to look at.
  • This isn't configurable, sorry.

    But I think this probably wasn't the right solution. We implemented this because, in our testing, the default San Francisco looked terrible on Catalina, and we were under the impression that a change in Catalina caused Zotero to use San Francisco instead of Lucida Grande on non-Retina displays. But comparing a clean Mojave VM to a Catalina VM, it looks like stock Mojave did use SF, but just with much more legible typesetting.

    (We were seeing Lucida under Mojave an another non-Retina system, but that system appears to have been configured to use Lucida previously, and after resetting that, I see the same bad SF text in Zotero under Catalina.)

    So I think the proper solution here is to tweak the typesetting of SF on non-Retina displays, not to change the font altogether. We'll try to do that for the next version, and I'll post here when it's available to test in a beta.
  • I don't know how to fix it but it is very hard to look at.
    I'm not sure what you mean by that. To be clear, this change was made because SF looked terrible in Zotero at small sizes on non-Retina displays, and Lucida Grande was used for many years before that, so this was simply reverting to an earlier font. Lucida Grande should look great in general.

    It's just that there's probably a better fix that won't require using a font that doesn't match the rest of current macOS.
  • We're not currently able to fix the SF rendering under Catalina, so in the latest Zotero beta we're now just forcing Lucida Grande, which renders properly, on both non-Retina and Retina displays on macOS. We should be able to restore San Francisco with proper rendering in a future version.
  • Let's user decide. We can set the note font and font magnifation of the UI. Why not give an option to set the default font of the interface?
  • Is this only a zotero issue? I find it SF Pro supplied by Apple, particularly the text variant, just looks awesome even on a non-retina display.
  • It's a Firefox-related bug (Zotero uses Firefox as a base). See here for details: https://github.com/zotero/zotero-standalone-build/commit/ed5d5efcc
  • edited 21 days ago
    Lucida Grande in Zotero 5 on the Mac was driving me nuts. I did some digging on the forums and followed the instructions here to add to override the style rule forcing Lucida Grande: https://forums.zotero.org/discussion/66421/customizing-5-0-user-interface

    In short, I created a new folder called "Chrome" at the in the profile directory on my Mac:

    /Users/*USERNAME*/Library/Application Support/Zotero/Profiles/*.default/Chrome

    In the new "Chrome" folder, I created a new css file called "userChrome.css" with the following style rule to set all text in San Francisco:

    * {
    font-family: SF Pro Text, -apple-system, sans-serif !important;
    }


    Apple's SF font comes in a variety of flavors; I found "SF Pro Text" works best, but you may need to download it from Apple to invoke it by name in the stylesheet. Otherwise "-apple-system" should work.

    Save stylesheet. Restart Zotero.

    I haven't discovered any problems so far, and the interface looks way better now! I hope this can get fixed for everyone soon.
  • @jmoses: I assume you're on a Retina display, but note that this isn't a fix. SF still renders terribly in Zotero on non-Retina displays, and badly on Retina displays. On the former, text is extremely compressed. On the latter, text isn't kerned properly and is spread out more than it should be. The latter is more tolerable and can pass as acceptable if you're not picky, but it's not correct. You might reasonably prefer it to Lucida Grande in the context of the rest of your system, but Lucida is at least rendered properly.
  • @dstillman I am on a Retina display (13-inch MacBook Pro). But, in my view, text in Zotero is rendering correctly with SF Pro Text without any of the spacing problems you describe. If I force Zotero to open up in Low Resolution mode, it also looks fine to me.

    Here are two screenshots of what I'm seeing:
  • Ah, sorry, I missed the part where you said you downloaded SF Pro from Apple. That's true — that works fine. It's the rendering of -apple-system that's off, and that's why we can't currently default to that.
Sign In or Register to comment.