Zotero problems, unresponsive

Dear Zotero colleagues, I am having increasing problems with Zotero. I am working on a (rather urgent) Word document (2016 version of Word, fully updated, on Windows 10 pc, fully updated). in the past week or so I have started to have problems, mostly with Zotero not responding when I try to insert or edit a citation through the Word plug-in. Normally, Zotero does not respond. Also, I am now getting a problem of Zotero stand alone programme become unresponsive. Also, I get error messages, including that the template (or something similar) is not available. I have tried various things from the support pages including checking that the .dotm file is in the right place, and also moving my files from Onedrive for business to the hard drive of the computor, and the problems remain. I have tried unistalling/reinstalling Zotero, and shutting Word and Zotero down and restarting the computer, which sometimes seems to help, but then it will start being unresponsive again very soon. Also, when I try to restart Zotero after closing it down I also get a message saying that Zotero is still running and needs to close, even though it doesn't seem to be running. Zotero has become basically unusable at the moment, and I'd be very glad for your help. Thank you.
  • What do you mean by "Zotero becomes unresponsive"? When you click Add/Edit Citation in Word, what happens and how long do you wait? If the citation box does not show up, is the Zotero window itself still responsive and you can look through your library, etc?
  • edited October 14, 2019
    Thank you for your response and request for further info, apologies I wasn't very clear. The main problem seems to go as follows:

    1) I have word add-in and Zotero stand alone open, I try to insert a citation by pressing the 'Add/Edit Citation' button in Word.
    2) the citation box does not appear, none of the other buttons in Zotero plug-in for Word work
    3) when i go back to Zotero standalone the programme does not respond to anything, so I can't move around the collections/subcollections, none of the buttons like 'File', 'Edit', 'tools' etc. work, and I can't close it using the 'x' box.
    4) I close it by right clicking on the icon in the task bar.
    5) when I try to restart it, I get an error message saying Zotero is still open (or working, something like that), and needs to close, I click a button to close it and then it starts (and the same process happens again).
    6) I'm needing to work on a doc urgently, so tried some other things last night after I posted the first entry in the forum
    7) I tried downloading Libreoffice, and couldn't get Zotero to work there either (I had errors relating to Java Runtime Enviroment, installed Java, the plug-in appeared, but wouldn't respond), uninstalled Libreoffice
    8) I noticed that in the standalone programme, it said that Word add-in was not installed, even though it was
    9) I went to the Word folder with the add-in, and deleted the .dotm file there (I think that's what is is called?), uninstalled Zotero, downloaded Zotero again, and reinstalled
    10) now the standalone programme says the Word add-in is installed, and it seems to work okay so far today
    11) other errors have appeared before I did step 9 last night, such as when I open a Word doc I get a message saying it cannot find the template (I think), something to do with the .dotm file (sorry, can't quite remember the details) - I tried the instructions on the website about trying to make sure the file was in the start-up folder, i'm now not getting this after I deleted that file and reinstalled Zotero.

    I hope this is of some help. Apologies if I'm not very clear about the technicalities, do ask if you need me to clarify something. I'll monitor the situation to see if the problem re-occurs.
  • Has there been any consistency to when Zotero freezes or was it random? Like attempting to edit or insert a citation in the same place would always result in a freeze? If you get a freeze, try performing the same operation in the same place in the document again after restarting Zotero and see whether it freezes again. Another thing you should report is Zotero's memory usage in the Task Manager when it freezes.
  • Thanks, I think it is random: different parts of a doc. c. 10,000 words. I will also keep an eye out for memory usage if it happens again. I should mention I'm about to take a break from writing for various reasons for a couple of weeks, so won't be using Zotero. I'll monitor it when I get back to writing. I was using it today a little and it seemed to work okay after the steps I took outlined above. I'll check back in to this thread if the problem re-occurs, thanks again for offering to help
Sign In or Register to comment.