Zotero not seeing its database

I run Palemoon (under Debian 10) and have Zotero I use it locally (no syncing) as a tab in the browser. It's been working fine for years. Yesterday I went to add a citation and the whole library is blank. I checked the database location in the browser zotero extension, but it's pointing to the right place.

I tried copying the whole zotero directory to a backup one, logged out and back in and restarted the browser, but still nothing. There's a 58MB zotero.sqlite file and 830 items in the "storage" dir, so things are still there. But inaccessible! Permissions haven't changed, user owns it all.

There is a zotero directory under home without either a database or a storage dir, and with a different random alphanumeric default user, but that's not where the browser addon zotero is pointing. I think I installed a standalone version to work with Libreoffice and maybe that's where that second dir comes from? I haven't actually tried to use it from within LO yet.

What's the best way to recover? I see people having database issues after upgrades to Zotero 5, so maybe that's not the best way?

Help, please! I'm dead in the water here!
  • (just as a heads-up, generally, 4.0 versions of Zotero aren't supported anymore, so if this is any sort of Zotero bug rather than just missing a step in instructions, you're out of luck, I'm afraid).

    When you say the library is blank, what exactly do you see? Can you take a screenshot and upload it somewhere? An empty Zotero library should have a "Welcome to Zotero item" in it.
  • @quixote7: You need to update to Zotero 5 before we can help you. If you're still not seeing your data in Zotero 5, see Data Missing After Zotero 5 Upgrade.
  • Thanks for the replies! I have nothing against upgrading, and if that's the likeliest route to a solution, I'm all for it. I'll look up how to upgrade manually. When I selected "check for updates" nothing showed up. I'll be back to report how it went :)
  • Zotero for Firefox no longer exists, which is why you're not being offered an upgrade. People running Firefox were upgraded to the Zotero Connector WebExtension a couple years ago.

    Full details here: https://www.zotero.org/blog/a-unified-zotero-experience/
  • Thanks, dstillman.

    I did the upgrade and -- Calloo! Callay! -- Zotero 5 finds my database. So at least I can access my work.

    The bad news is that the reason I use the browser I do is that I can't stand the Chrome (or Chromium) interface. Firefox the last time I looked was also down that rabbit hole. Maybe by now they have an extension to allow interface customization again, but I'll be surprised if they do. Do you know of a browser that handles WebExtension but isn't Chromified?

    Anyway, long story short, I'll look to see what's involved in importing citations to Zotero, manually I guess, when it's not connected to the browser.

    Thanks much for solving my really big problem of losing access to all my work!
  • Just to footnote my question about a WebExtensions-capable browser that is not chromified:

    Searching around I found Vivaldi. It comes pretty close. It's an offshoot of Opera. It can use Chrome extensions, so Zotero Connector seems to work fine.

    It has some weird quirks (I can't resize an unmaximised window) and the tab handling isn't what I'm used to, but it is a doable alternative and I suspect there are workarounds for the issues, once I can take the time to look for them.

Sign In or Register to comment.