Weird: attachment content search in PDF finds some search terms in one paper, but not others.

I discovered a weird phenomenon with a saved search in attachment contents.
The search specifies:

Matching all of the following:
Collection is [collection]
Attachment File Type is PDF
Attachment Content contains [search term]
[ ] Search subcollections
[ ] Show only top-level items
[X] Include parent and child items of matching items

I know at least one paper mentions the search term multiple times, including in the title, but the search returns nothing. There are no weird characters in the search term.
So I tried another search term, which also appears in this paper, and lo and behold, it showed up in the results with the alternative search term.
Opened the PDF in acrobat and searched for the search term: found it.
Reindexed the paper, tried again. Still doesn't show up with that first search term.

Any ideas what might solve that?

For reference, it's this paper, and the search term is "Lactofl".
Sign In or Register to comment.