Pdf files not uploading to Zotero

For the last few weeks, I am having difficulty in uploading pdf files to my online Zotero account. Tried different sized files and from different networked computers but none of them worked. It simply shows file uploading and stays like that. Left it overnight, but still the file wasnt uploaded. It cannot be a space related issue as I have unlimited storage space on my account. Any suggestions?
  • While that should work, is there a reason you're not using Zotero itself?

    A new version of the web library is coming very soon, so it's not worth debugging the current one, but for any real work you want to be using the Zotero program anyway.
  • I usually upload pdf files on to my online Zotero account and then sync the standalone with it. Is there any other way of doing it?
  • Yes, there's absolutely no reason to be uploading files to the website manually if you're using the Zotero program.

    Read through Adding Items to Zotero for the many better ways to get stuff into Zotero.
Sign In or Register to comment.