Help with Oxford EXProxy Settings for Zotero Connector?

edited September 20, 2019
Previously, I’ve been using a proxy address provided by my old institution (LSE) to access materials easily through Zotero Connector on Firefox (Mac). The string required was ''. This continues to successfully redirect my searches (e.g. on Google Scholar) through my old university’s SSO system and gives me quick access to files and PDFs. So far, so good – but I'm about to lose access to my LSE account.

This is because I've now moved to Oxford University, who appear to use EZProxy for redirections. The system is called 'proxy by port' and it's been suggested to me that '' should work... but I can't get it to redirect at all with any combinations of %h and %p appended to the beginning or end of the address.

Frustratingly, it seems like it almost works but not quite! For instance, I get a 404 error if I use '’ in Zotero’s preferences. The fullstop after the hostname string (%h) is clearly incorrect, I think, but after removing that fullstop Zotero no longer allows me to reload through a proxy at all, which is quite puzzling! When I right click the Zotero Connector there is simply no option to use the Oxford proxy, only my old LSE one.

What makes it particularly odd is that this naming scheme (excluding the fullstop) should make sense… e.g. If I copy paste any of the ezproxied links from this page ( into my browser, I get correctly rerouted through Oxford's SSO system and can login etc. It’s just Zotero that doesn’t manage to let me do that automatically with other pages! Trying strings like '’ or '’ for instance do not work.

I also tried '' but that didn’t work either… e.g. it fails to load '’ (as an example file to access).

Interestingly, if I remove the ‘login’ portion, I get a message form Oxford’s system telling me to add it back into the URL, so it’s seemingly getting through to Oxford’s system but not working for some other reason.

Finally, through manually loading some pages, Zotero is indeed automatically picking up the correct proxies and storing them for the future. '' now works for TandF online, for example, as does a similar one for ProQuest. Obviously I'd rather not manually enter a string for every single journal though, complete with customised port number.

So, is there some way to get Zotero to correctly route my proxy requests and automatically re-route any new searches through the proxy like it used to before I moved institutions? Any and all help would be greatly appreciated!
  • edited September 24, 2019
    Take the existing TandF entry and change the scheme to Navigate to another journal that should work with the Oxford proxy. Right click the Zotero connector and navigate into the Reload via Proxy menu (you just need to make it appear once so that any errors are logged by Zotero). After that please submit a Report ID from the Connector.
  • Thanks for your help!

    I've just attempted to follow your instructions but, unfortunately, changing the scheme has again resulted in the option to reload via that particular proxy to disappear from the Zotero Connector options.

    I've submitted a report, though. Hopefully that might provide some insight? The ID is 906893744.

    There was also the error message '[JavaScript Error: "Frame not found, or missing host permission" {file: "undefined"}]' in the Connector's advanced section – not sure if that is of any use to you?

    Many thanks, again, for your advice!
  • So I spent some time looking into the code for this and unfortunately there is no scheme you could enter in the current system, even with minor adjustments to the underlying code, to make it work better. Handling proxy-by-port systems would require a fair amount of additional work on our part to get it working and the demand for this is just not high enough, especially since proxy-by-port is considered a legacy system and most proxy users are switching away to proxy-by-hostname.
  • That's a shame but not overly surprising given the legacy nature of the system, I suppose. I can only thank you for looking into this for me! I will try and figure out some other option – might just manually go through with a lot of the most used journals and manually enter their port numbers. Either way, thanks again and I really appreciate the time you've spent seeing if there was anything that might work!
Sign In or Register to comment.