Google Docs integration broken in 5.0.58

Since updating to plugin version 5.0.58, I'm having issues with the Google Docs plugin (both Chrome and Firefox and across multiple devices). Rather than populating the citation editor with the current citation (if editing a citation) or a blank (when adding a new citation), the citation editor continually returns to the last edited citation. I've tried uninstalling and reinstalling the plugin to no avail. Suggestions?
  • Sorry about that — a recent change in Google Docs broke citation editing, but it looks like our fix in 5.0.58 caused more problems. We've reverted that for now while we work on a better fix. Version 5.0.59 is out already for Firefox, and it will be available for Chrome shortly.

    Thanks for reporting.
  • Excellent! Thank you!
  • leaving a +1 so I can get notified of any followups (like the chrome release). Thanks!
  • edited 12 days ago
    The 5.0.59 release for Chrome is out already.
  • perfect, thank you!
  • @dstillman on Chromium for Linux with Zotero plugin 5.0.59, when I try to edit an existing citation, the dialog comes up empty, and if I press escape it erases the old citation as well.
  • @MavropaliasG Yes, this is a bug we were initially trying to fix, but ended up breaking something else. Google has made some modifications to the Docs editor recently causing this. We will have a fix out for this soon.
  • Just chiming in here to say how much I love this community. Came here to report the same problem that I and the two dozen students I was teaching yesterday afternoon experienced, only to find out it's already been fixed. @dstillman @adomasven, y'all are heroes!
  • Thank you very much @adomasven and @dstillman
  • @MavropaliasG, @delinkd Could you test the Zotero Beta Connector on Firefox for the citation editing fix?
  • edited 10 days ago
    Has this been fixed for Chrome yet? Sorry if it has - I couldn't work that out from this message chain (I'm still having the problems @MavropaliasG describes).
  • No, we’re not able to put out beta releases for Chrome. Once we have confirmation that the beta fixes the problem in Firefox, we’ll put out a release version for both browsers.
  • @adomasven I have installed 5.0.60beta1 on firefox for linux (manjaro KDE) and when I went to google docs, I added a citation and tried to edit the existing citation (i randomly chose the style Springer - Lecure Notes in Computer Science) it tells me 'Zotero fields cannot be inserted here.'
  • @MavropaliasG Can you reproduce this behaviour consistently? If so, could you provide a step-by-step procedure?
  • @adomasven I'm getting same bug as @MavropaliasG for 5.0.60beta1 on Firefox Quantum 69.0 (64-bit).
  • @MavropaliasG @pathwaycommons Please check for the plugin updates, we've pushed another update that should fix the "Zotero fields cannot be inserted here" bug
  • Zotero Connector 5.0.60 is now available for Firefox and Chrome with fixes for citation editing and for "Zotero fields cannot be inserted here".
Sign In or Register to comment.