I can't select attachment folder on second computer (Zotfile or Base Directory)

Ok this seems like a daft problem. I'll try to explain as clearly as possible.

I have moved my Zotero attachments to an iCloud folder so I can access from a tablet.

I have 2 computers: Desktop running MacOS High Sierra and a laptop running MacOs Mojave.

I did the initial move on the desktop using the instruction provided on another thread here. This worked wholly as expected. I selected the new folder (iCloud/Zotero_attachements) pointed Zotfile and the base directory preference at it, clicked rename all and everything was moved into the correct folder, and I could open attachments from within Zotero as before - success.

In order to make sure the laptop Zotero was synced with the desktop version I then did the same thing on the laptop. But I can't. If I go to either Zotfile preferences or the Base Directory preference and select 'iCloud/Zotero_attachments' the directory gets truncated so it say:

/Users/mymac/Library/Mobile Documents/com~apple~CloudDocs

where it should point to:

/Users/mymac/Library/Mobile Documents/com~apple~CloudDocs/Zotero_attachements

The field is also locked so that I can't add the additional path information to the text.

I did try and run it anyway (I wondered if perhaps the on screen text field was too short, but the full path was saved ). This 'worked' but placed all of the attachments in the top-level of my iCloud folder (i.e. the laptop now points to a different set of attachements than the desktop).

Has anyone come across this before / know what I'm doing wrong??

  • edited 20 days ago
    OK I think i fixed it and am leaving this for anyone else. I still can't select the correct folder on the laptop. So I copied the path from the Zotfile preference pane on the desktop and saved it to a note file so it synced to the laptop. Then pasted it into the relevant field in Zotero Base Directory preference and in the Zotfile preference on the laptop.

    Simple fix and seems to work. but I've not a clue why I can select a folder on one computer but not on the other... weird!
  • Ok - I spoke to soon. This morning I imported some PDF's using safari on the laptop. I noticed that the PDF had been imported into the Zotero data folder not the iCloud folder I had selected.

    When I checked the preferences, Base directory preference in Zotero was now blank (this was where I had previously pasted the path to the specific iCloud file for attachments). The path in Zotfile is still correct, so if I rename with Zotfile, the PDF gets moved to the correct file. This if fine, except occasionally Zotfile doesn't auto- trigger so the file doesn't get moved.


    I suspect this may be an iCloud thing as if I select a base folder in a sub-level of dropbox everything works as intended (I just don't have enough space in my Dropbox account to hold everything).

    The thing is, I have no clue how to trouble shoot this. There are no error messages to work from. When I select the correct iCloud file, everything *seems* like its worked and a new base path is put into the Zotero preferences pane. It is only when you look at this closely you realise that the path inserted into the preferences doesn't point to the folder you selected, but the top level of the iCloud folder.

    Any suggestions gratefully received....
  • Note that Zotero without add-ons _never_ auto-moves.
    The base folder just establishes relative paths for existing links, so if ZotFile doesn't move (e.g. after retrieving metadata for PDFs), you'll have to manually trigger the move.

    Not sure why the base directory isn't stored, though, that should certainly work and since I assume iCloud is just a general harddisk location, I don't see how that should matter.
Sign In or Register to comment.