Custom style with first author only and no "et al."

edited 28 days ago
For my Word document, I would like to set up a custom Zotero style that consists of the only of the first author's name followed by the year (no "et al."), e.g. "Smith 2001".

Following Zotero documentation, I imported the apa.csl file into the visualEditor at editor.citationstyles.org/visualEditor/ and proceed to customise it; however, I am having trouble achieving my aim:

1) Under the "inline citations" options, I've set "et-al-min" to 2, but saw no option that can hide the "et al." itself

2) When saving the style as a local file and importing it into Zotero (from Preferences|CiteManager), I get the message "An unexpected error occurred while installing fileName.csl".
  • due to a quirk, setting et-al-min to 1 and et-al-use-first to 1 will get you what you want (I'd assume this will keep working, but no promises; it's not something CSL specifies).

    See if the style still won't install, if so provide an error report ID.
  • Got it to work, thank you very much!
Sign In or Register to comment.