problem indexing PDF


I got a new computer and after I installed zotero I imported my library from the old computer. Since then I have problem with indexing PDF files...
I would be grateful to get some help...

thanks in advance,
  • What exactly is your problem?
  • when I use "Linke to File" the file is added to the library but it wrote "indexed: No". its mean that it didn't succeed to take out the information of the text (Author for example).
    I tried to drag a file to Zotero and it is only in this way that it manages to index.
  • No, that’s not what “indexed” means. It means that the full text of the pdf is searchable.

    To add the metadata to a linked file, right click on the item and choose Retrieve Metadata for PDF. You can also drag the file into Zotero while holding down Shift to add a linked file and have it retrieve metadata automatically.

    Note that this isn’t the best way to add items to Zotero. The best way is to use the Save to Zotero button from your web browser on the publisher web page. See for details.
  • I tried both to "Retrive Metadata for PDF" and to add the files through Zetoro button in my browser and it didn't work, appeared an error "Could not read text from PDF". I tried to do it several times with diferents files... only when I drag (the same) files to Zotero the "retrive metadata" works.
  • "Retrieve Metadata for PDF" runs by default when you drag PDFs to Zotero, and there shouldn't be a difference between that and triggering it later via the context menu.

    Can you provide a Debug ID for a Retrieve Metadata for PDF attempt that fails?
  • The Debug ID that appeared when I use "linke to file" and the automatically "Retrieve Metadata for PDF" failed is D1023316315.

    And the Debug ID that apeared when I click on the item and choose "Retrieve Metadata for PDF" is D491084879.
  • edited August 23, 2019
    Does it work if you try a linked file on a path without extended (non-Latin) characters?
  • No, it doens't work either.
  • Can you provide a Debug ID for that?

    Does it work for files outside of OneDrive?
  • Here is the Debug ID D727660749 when I tried a linked file on a path without extended characters (from my desktop).

    It's working for files outside of OneDrive (Downloads for example) but in my computer almost all the folders are syncing automatically to OneDrive.
  • edited August 23, 2019
    That debug output still showed a path with extended characters — the name of the desktop folder itself.

    Can you just try a file in the OneDrive root?
  • and now - D1174223869
    my windows display language is English (united states).
    In my old computer the Zotero worked perfectly and I had the same folders and settings.
  • That's still a path with extended characters. You have a non-English install of Windows, so even though you have it set to use English as the display setting, the underlying name of the desktop folder isn't in English.

    If you didn't see my edited message above, you should try in the OneDrive root itself — not a subfolder.
  • I tried in the OneDrive root itself - and it worked!

    Does it mean I need to change all the folders' name to English? In my old computer I had exactly the same folders so I wonder why now it doesn't work.
  • I'm not sure you can change them — they're part of the system configuration, based on the language of the Windows install.

    Some people have had trouble indexing files on paths with extended characters on Windows, but I don't recall whether that's a universal problem. We're working on replacing the PDF text-scanning process in a way that should avoid this problem.

    In the meantime, I wouldn't try to rename anything. You can just create a folder without extended characters in the OneDrive root and use that for your PDFs. You can move your existing PDFs there without breaking them by setting the linked attachment base directory to the current location (which should convert all the existing attachments to relative paths), moving the files, and updating the base directory to point to the new location. If you do that right, Zotero will still be able to find the files in the new location.
Sign In or Register to comment.