Error installing Word plugin on Mac

edited August 16, 2019
This discussion was created from comments split from: Zotero not integrating MS Word for Mac (v16.27).
  • Hi there, I have a similar issue (v16.28).

    The plug in is enabled (I disabled and enabled to be sure). When I go to the cite pain - the button offers to install Microsoft Word Add In. If I click this, I get the following error:
    "Installation could not be completed because an error occurred.

    [Exception... "Word does not appear to be installed on this computer. Please install Microsoft Word, then try again. @[install:install.m:183]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Users/benhunt/Library/Application%20Support/Zotero/Profiles/e09s84do.default/extensions/ :: checkStatus :: line 211" data: no]"

    Any help you can offer would be most appreciated.


  • edited August 16, 2019
    Can you provide a Report ID?

    Are you running any security software on this computer? Is Word present in the normal location in the Applications folder?

    In any case, you can try the manual installation instructions.
  • Thank you for the quick response. Report ID: 1743449889.

    No - no security and yes, it is in the applications folder.

    Will follow the manual install instructions.

    I also found that the Zotero.dotm is not installed in the Templates and Add-In's but I assume the manual install will fix this.

    Thanks again :-)
  • edited August 16, 2019
    Zotero Word for Mac Integration (3.5.14.r10158, extension)
    OK, no, you have an ancient version of the Word plugin that you installed manually in Zotero. The current Word plugin is bundled with Zotero, so you should uninstall that from Tools → Add-ons → Extensions. (It should already show as incompatible with the current version.)
  • Oh OK! It didn't show as incompatible... I removed it and restarted Zotero. I now have 5.0.24.SA.5.0.73 - should that work?
  • OK - so I don't see anything different in Word. I have restarted both Word and Zotero. There is still no Zotero.dotm in the Templates and Add Ins - should I add it manually?
  • You can, but did you reinstall from the Cite pane?
  • Ahh - no I didn't. But with Word open or closed I get Installation could not be completed because an error occurred.

    [Exception... "Zotero.dotm couldn't be copied to Word. @[installContainerTemplate:install.m:269]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/ :: checkStatus :: line 227" data: no]

    Report ID: 2099266928
  • That's odd. I don't think anyone has ever reported that error. @adomasven might have some questions, but you can just copy the file manually.
  • Ahh - I am special?!

    I have clicked the plus button in the Templated and Add-Ins and navigated to /Applications/ but the .dotm is faded out and I can't click it...

    Any ideas?!
  • That’s not in the instructions.
  • Ahh sorry - I am getting confused with something else I read on your website!

    This may not be an answer you know, but I don't seem to have a start up path for my word (there is no path listed in the file locations). Do you have any idea where I would find it? I can access the Applications/Microsoft Word/Contents/ directory.


  • edited August 16, 2019
    If there is no location listed, the default location is ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word (i.e., the Library folder within your home directory). The ~/Library folder is hidden by default, but you can open it from the Finder by holding down Option, clicking the Go menu, and selecting Library. You can also press Cmd-Shift-G in Finder and copy the path above to navigate to that folder.
  • I have the following path ⁨Library⁩ ▸ ⁨Group Containers⁩ ▸ ⁨UBF8T346G9.Office⁩ ▸ ⁨User Content⁩ ▸ ⁨Startup but 'Word' is a broken alias... should I just put the .dotm into the directory along with the alias?
  • edited August 16, 2019
    Weird. If you do Get Info on the alias, what's the Original path?

    That would certainly explain why the installation isn't working for you.

    You should likely just delete the alias, recreate it as a normal folder, and copy the .dotm to it, but I'd be curious to know first where it was pointing.
  • It says the original file can't be found so I guess I can't find where it was originally pointing? The issue is I don't know where the original is to recreate it!?
  • File → Get Info
  • But the point is that you would just delete the alias and recreate that folder. That's not supposed to be an alias.
  • So the file -> get info just tells me the location of the alias?

    Ahh OK - so I just make a new folder and name it Word?

    Sorry I am being stupid here...
  • edited August 16, 2019
    If you do File → Get Info on the alias, there's an Original field that tells you where the alias is pointing. I'm asking what it says.
  • Yes - maybe I am not being clear. The alias is broken so I can only choose to select a new original, there is no original field.
  • OK, just delete the alias and create a new Word folder.
  • Hurrah - it worked!!!

    Thank you very much for your help :-)

Sign In or Register to comment.