Step-by-Step Instructions for Installing Zotero Standalone on Chrome OS/Chromebook

edited August 14, 2019
After a series of false starts and my own lack of deep knowledge of using the Linux Terminal, I was finally able to successfully get Zotero Standalone 5.0+ working on my Chromebook. I thought it might help others to provide a handy step-by-step guide to installing it, so you can avoid the pitfalls I had.

The first thing to know going into this is, for some odd reason, the default Debian Packages only has Zotero Standalone 4.0+, not the most recent version. Additionally, even if you get it installed, the "Preferences" will never open, allowing you input your Zotero login credentials and sync your data.

**STEP 1: Allow Chrome OS to Install Linux**
1. On your Chromebook, open "Settings," then click the "hamburger" menu at the upper left (it looks like three horizontal lines).
2. In the side menu that opens, click the "Linux (Beta)" option.
3. Go through the process of installing Linux on your Chromebook.

**STEP 2: Open Terminal**
1. After Linux is installed on your Chromebook, you will notice a new app folder in your overflow menu (where all your app icons live) called "Linux apps." Click on this folder and select "Terminal."
2. Wait for the Terminal app to open. This might take a few minutes the first time.

**STEP 3: Install Zotero Standalone Using Terminal Commands**
*I used the instructions at this Github page to successfully install the most recent version of Zotero Standalone to my Chromebook:*

1. Enter these commands in Terminal to install Zotero Standalone 5.0+:
`wget -qO- | sudo bash
sudo apt update
sudo apt install zotero~

2. Once that finishes, enter these commands in Terminal to install an additional package called Juris-m (required for this version of Zotero Standalone and its constant updates):
`wget -qO- | sudo bash
sudo apt update
sudo apt install jurism`
[Edit: This is incorrect. See below. — D.S]

3. Once those are done, you can close the Terminal and go back to the "Linux apps" folder. Inside you will now see an icon for Zotero, and clicking on it will open the app, as normal. You can then pin the app to your Chrome Launcher.

Final Notes: on my Chromebook at least, the Zotero app icon does not actually show the Zotero icon, but a default "penguin" app related to Linux. Just a minor point, and it does not seem to affect Zotero's performance at all.

Also, as discussed elsewhere on the forum by @jackyko1991 , to use Zotero Standalone with the Google Docs integration, do the following:
`what I have done is to install a port forwarding app:

set forwarding rule as following:
source: (anywhere) port 23119 (connection port from chrome)
destination: port 8080 (target port in crostini vm)

and set the zotero http port to 8080 (default port 23119 will crash the os), this port is arbitary but be careful not crash with other crostini ports, and must the same as the destination port

in zotero:
Edit -> Preference -> Advanced -> Config Editor -> Accept -> extension.zotero.httpServer.port -> double click and set to 8080`
  • Once that finishes, enter these commands in Terminal to install an additional package called Juris-m (required for this version of Zotero Standalone and its constant updates)
    What exactly do you mean by that? Just to be clear, Juris-M is a completely separate program from Zotero — it's a community-created fork of Zotero intended for multilingual and legal citations that you would generally run in place of Zotero. If you're just trying to use Zotero, Juris-M certainly isn't something you would need to install.
  • Hi @dstillman , I was not aware that Juris-m was not needed. According to the description on their Github page, it seemed like it was needed to keep Zotero up to date. Is that not the case?
  • No. I don't know what description you're referring to, but as I say, Juris-M is a completely separate program from Zotero.
  • @dstillman , from the Zotero/Juris-M Githug page (for what it's worth):

    "The Zotero / Juris-M programs provided by this repository have their self-update facility disabled.

    Simply rely on on your system's package manager to give you update notifications when a new version comes out."

    If there is an easier, more direct way to do this using only the Zotero download from the terminal, please let me know!
  • First, that's not the "Zotero/Juris-M GitHub page" — that's the GitHub page for the Linux packages provided by @emilianoeheyns.

    But then I'm not sure why you think that's saying you need Juris-M to update Zotero. The whole page is describing packages for both Zotero and Juris-M. This is just saying that both the Zotero and Juris-M versions distributed this way have their self-update mechanisms disabled and that you need to rely on the system package manager to update them. In no way is this saying that you need to install the Juris-M package if you just want to use Zotero.
  • edited August 14, 2019
    Thanks for the clarification, @dstillman . I obviously misunderstood the page (being combined on one Github page, I misunderstood the title of it). Obviously I am not tech-savvy with Linux and packages, but with all due respect, I am simply trying to offer an easy step-by-step set of instructions for installing Zotero on a Chromebook that I could not find easily elsewhere within Zotero's official documentation (and that worked for me).

    The installation page for the Linux package simply requests downloading the package directly and then offers commands to unpack it...but, frankly, it is unclear if those examples listed will work in the sandboxed way Chromebook handles Linux installations (it might, I don't know). If so, perhaps the installation instructions could mention those directions will work on Chromebook as well?
  • And thanks to @emilianoeheyns for providing those packages and instructions!
  • I'm still trying to figure out how to get this installed onto my computer. I need this because I'm in grad school and currently only use a chromebook.

    So can someone explain..this is my first time attempting to use linux on my chromebook
  • The instructions by @Cosmosis seem to be fairly comprehensive, at which step do you get stuck?

    @Cosmosis I've copied the instructions to the zotero-deb wiki for easier finding, with minor edits. The Wiki is publicly editable.
  • @emilianoeheyns I've tried multiple times to get this return and I have no experience running or using Linux. I really just need to be able to store my references and use them. If you can help me figure out how to do that, that will be great...I've tried multiple ways.
  • Can't really help you, sorry; I've copied the instructions so they're easier to find, but I don't own a Chromebook so I can't do the steps myself.
  • First, thanks for posting these instructions in the wiki, @emilianoeheyns !

    Second, @rlwestre , you are welcome to hit me up directly if you need help. That being said, the instructions I posted are basically step-by-step what I did to install it on my Chromebook. I guess my first question is, have you activated Linux on your Chromebook?
  • Hi,
    At first i'm sorry for my english very bad.
    I came here because i run the commands you explain in your differences steps but nothing happen.
    I don't understand where is my mistake.

    I wrote this commands on the terminal :
    `wget -qO- | sudo bash
    sudo apt update
    sudo apt install zotero~

    But nothing is happening

    Someone can help me ?

  • Don’t type the ` character in the command.
  • Hi,

    First, I'm sorry if my english makes you cry :')

    I got a Chromebook not too long ago, and I just discovered today I could install Zotero on it. It made my day, but I've got a little problem...

    I followed all the steps and the terminal seems to have installed it all. But when I go to my linux apps folder, I don't have an icon Zotero... I just have the file...

    I tried again all the steps and here are the last sentences my terminal give me :
    zotero is already the nexest version (5.0.75).
    0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.

    Thanks for helping me ;-;
  • Hi there - I'm trying to install Zotero using the instructions above but it's not working. The error message in Linux Terminal is "Unable to locate package zotero".
    Can anyone help me please?
  • What do you get after
    wget -qO- | sudo bash
  • I get:
    deb/releases/download/apt-get/ | sudo bash
    deb ./

    The problem comes after I input:
    sudo apt install zotero

    What I get then is:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package zotero
  • And in case it's useful, here's what I get after the line sudo apt update:
    Ign:1 stretch InRelease
    Hit:3 stretch Release
    Hit:8 llvm-toolchain-stretch-7 InRelease
    Ign:4 stretch InRelease
    Hit:6 stretch/updates InRelease
    Hit:7 stretch-backports InRelease
    Hit:2 ./ InRelease
    Hit:9 stretch Release
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    20 packages can be upgraded. Run 'apt list --upgradable' to see them.
    N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository ' llvm-toolchain-stretch-7 InRelease' doesn't support architecture 'arm64'

    Thanks in advance for any help.
  • odd, that looks right. Could you try uname -m in the terminal and see what it says?
  • It gives me:
  • I'm sorry -- that indicates that your Chromebook runs on ARM architecture, which doesn't support Zotero

    @emilianoeheyns would it be possible to check on that as part of to give people a more meaningful error? Tim isn't the first who has tried to install Zotero on an ARM Chromebook
  • Ah ok, thanks for your help anyhow, much appreciated.
  • This check has been added. It will now report that it's not a supported architecture and will not create /etc/apt/sources.list.d/zotero.list. If the file exists, it's unaffected, it does not remove the file if it's unnecessary.
  • Hi, thanks for these instructions @Cosmosis . I have got as far as Step 3, i.e. I have installed Linux on my chromebook and now have the 'terminus' window. However, the link that you provided for the 'github' instructions doesn't seem to work any more. Please could you either send a new link, or alternatively write out the instructions of what to do? (in REALLY simple language please - I really don't understand what I'm doing!!) I'd be super grateful! Thanks :)
  • The instructions are still here:
    (the post above just includes the * in the URL, breaking it)
  • Thank you very much! I've managed to install it :)

    The problem is now that Zotero Connector doesn't seem to recognise that I have the app, and I can't save any sources to it.

    Is there something else I need to do?

    Many thanks!
  • edited November 23, 2019
    Did you do step 4? Is zotero running?
  • Hi there

    I've managed to get everything done but I am getting the error Unable to locate package Zotero. I have used uname -m and the return I am getting is x86_64

    Can you help please
Sign In or Register to comment.