APA 6th Edition - Query about Blog Post Reference section. Zotero not showing the [Blog Post]

edited 11 days ago
Hello,

I just referenced a blog post using Zotero and noticed that [Blog Post] did not show up after the Blog title which seems to be the correct format (Checked a lot of sites). Is there some setting I need to edit in Zotero, or my referencing is correct.

Platform - Using Zotero on Google doc, my version of MS Word does not support Zotero
Ref - APA 6th Ed
The Blog post - http://www.drjeffcornwall.com/2018/02/25/just-because-nobody-is-doing-it-is-not-a-reason-to-launch/

My output - Cornwall, J. (2018, February 25). Just Because Nobody is Doing it is not a Reason to Launch. Retrieved August 8, 2019, from Dr Jeff Cornwall website: http://www.drjeffcornwall.com/2018/02/25/just-because-nobody-is-doing-it-is-not-a-reason-to-launch/

Any help will be appreciated.

Thanks,
Veer
  • Enter "Blog post" in the "Website Type" field. APA style is very diverse when it comes to the descriptive text in brackets, and the "Blog Post" item type could be used for a lot of different types of content, some of which wouldn't include any brackets text, such as an "informally published or self-archived work" (example 61 in the manual, example 67 in the 2012 guide to electronic references). So, the style leaves it up to the user to specify the type of special content description, if any.

    You should also delete "Dr Jeff Cornwall" from the the "Blog Title" field.
Sign In or Register to comment.