firefox connector not working

been using Chrome for a long time. works fine. Moving to Firefox. Installed connector. But simply doesnt seem to be live. Right clicking gets usual, 2 save to zotero options, but they do not appear to save. using current Firefox and zotero.

I assume this is just somethign stupid I didn't enable, but I dont see it and cannot see documentation that would help
  • What happens, exactly?

    Generally, see Troubleshooting Translator Errors.
  • Connector is either greyed out or blue. clicking it generates no action at all. right click offers 3 zotero save options, but none of them work. Both zotero and firefox are up to date.
  • See the linked page.
  • so
    I see the icon
    Greyed out for all sites (sometimes blue but doesnt wowrk anyway)
    Site sfully loaded
    Tried restarting browser\
    zotero is running and chrome works perfectly
    Connector gives no fresponse at all
    Connector installed yesrday so up to date
    Browser up to date
    Zotero current version
    No known translator issues
    Shows no tooltip on hover
    standard setting for cookies
    Tried uninstalling and reinstalling. only have ad block purevpn and dashlane password manager running. will try disabling and reloading in a minute
    tried resetting translators

    The exact URL: all eg
    Cannot see where to getg Debug ID from Connectopr; it's basically nonresponsive

    says nothing on popup (no popup)

  • OK working now! seems like it really didnt like me using a VPN from Greece. thanks for the help
  • It may not have been your VPN. I've noticed several other situations where Zotero will do that. I'm afraid that I don't recall if it was happening in just Opera or if it was happening in Firefox as well. One scenario was that the button on the extension bar was 'grayed out' and clicking on it wouldn't do anything obvious. However, if you moved your mouse cursor down over some text in the web page you were trying to reference and right clicked on it, Zotero would appear in the pop-up menu and you could generally save the reference from there. This seemed to be resolved by updating to the current version of the connector (Version 4.0.26 to Version 5.0.57), so you could use the button or the pop-up menu.

    Another scenario which I encountered occasionally was in Opera while using 'The Printliminator' Extension. In this case, neither technique would save the reference. Refreshing the web page and attempting to save in Zotero without using 'The Printliminator' would then generally work. I don't know what part of the web page that 'The Printliminator' was hiding prevented Zotero from working, as other times it would work fine with this extension. I suspect that the variation was due to how a specific web page was created. With the plethora of ways that a given web page can be generated, it can be difficult to code an extension that can handle all possible contingencies, particularly if you have one or more other extensions interacting with each other.

    I hope this helps prevent someone else from beating their head against a wall!

Sign In or Register to comment.