HeinOnline - Articles not saving

edited 6 days ago
Hi,

I'm trying to save articles on HeinOnline using the Zotero connector. It doesn't seem to be able to grab the page information at all.

This is the URL of the article that I'm trying to save:
https://heinonline.org/HOL/Page?handle=hein.journals/utahlr2003&div=32&g_sent=1&casa_token=&collection=journals

I've tried using Zotero Connector on Chromium and Firefox. I'm using Ubuntu 18.04.

My Debug ID is D594905754.

I believe I've pasted below the debug output from Zotero standalone, after I tried to grab the HeinOnline page using Chromium:

(5)(+0007468): POST /connector/delaySync HTTP/1.1 Host: 127.0.0.1:23119 Connection: keep-alive Content-Length: 2 X-Zotero-Version: 5.0.56 Origin: chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc X-Zotero-Connector-API-Version: 2 User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) snap Chromium/75.0.3770.100 Chrome/75.0.3770.100 Safari/537.36 DNT: 1 Content-Type: application/json Accept: */* Accept-Encoding: gzip, deflate, br Accept-Language: en-US,en;q=0.9

(5)(+0000008): HTTP/1.0 204 No Content X-Zotero-Version: 5.0.69 X-Zotero-Connector-API-Version: 2 Content-Length: 0

  • I'm having the same problem. Debug ID is D347493025.
  • The problem is that the RIS data that HeinOnline provide is not valid anymore. You can see that, when you click on "Cite" on the left side of the website and then go down the list to "Export to RIS file". This file is what Zotero will also use. There are two problems with that now: 1) the keys and values in the RIS file are not separated by a hyphen "-", 2) the file does not start with the type tag "TY", see also https://en.wikipedia.org/wiki/RIS_(file_format). Can you please contact the provider HeinOnline to ask for fixing this issues with their RIS export?
  • I have contacted HeinOnline support by sending an email to holsupport@wshein.com
Sign In or Register to comment.