Removing file links in bibliography

Hello everyone,

I´ve been using Zotero recently for my thesis and I´m happy with it so far. While writing with Texpad I´m getting errors now and then because of the file links in the bibliography. Is there any way to determine which information should be copied to the bibliography and which shouldn´t ? Because I don´t need those file links in my thesis and they cause a lot of trouble when trying to find the source which is faulty.
Same goes for the Abstract, but this hasn´t caused errors lately.

Thanks for your help! :)
  • The BetterBibTeX add-on lets you customize bibtex export (and you'll likely want to use it anyway if you're working with bibtex -- I think I'm understanding correctly that that's what you're doing.
  • edited 5 days ago
    Thank you for your help! I installed Better BibTex which makes it easier to work with but which field do I have to omit from the export in the preferences if I want to get rid of my local file link?
    I looked up all the fields here:

    https://www.zotero.org/support/kb/item_types_and_fields

    In my Texpad bibliography it says: file = [..../Zotero/storage]

    That´s the part I don´t want there.
  • I found the solution to the problem.

    I deleted my .bib file (backed it up)
    - closed Texpad
    - then changed the Zotero / BBT Preferences to omit `File´ and ´file´
    - restarted Zotero
    - restarted Texpad

    Now it´s working like I want it to :-)

    Thanks again!
  • edited 5 days ago
    You should only have to include one of them -- Fields to omit is case-insensitive. Restarting Zotero should also not be required.

    Fields for BBT means the bib(la)tex fields it exports, correct.
Sign In or Register to comment.