Word integration VBA corrupted - [SOLVED]

edited July 8, 2019
Office365/Win10

This is definitely a Word issue but maybe some of you can help.
When trying to do anything with Zotero I get this:
Run-time error '5891': Could not open macro storage
https://screenpresso.com/=gL59g
Macros are all enabled, VBA is enabled.
Under templates I actually cannot remove Zotero from Word - Remove button is disabled.
https://screenpresso.com/=3B7Tc

None of the macros actually work and when I try to make a new one I get error that The macro could not be created. Editor for the existing macros does not open.

Tried fast repair, slow repair, reinstalling, checked permissions, run as administrator, delete VBA key from registry, but nothing works.

Any help is greatly appreciated, I am kind of under pressure.
Thanks!
  • edited July 8, 2019
    There haven't been other reports of this for 10 years, so I'm not sure we'll have much to suggest.

    You've tried uninstalling and reinstalling Word?
    Under templates I actually cannot remove Zotero from Word - Remove button is disabled.
    The template is loaded automatically from the Word startup folder, so you'd want to remove it from there, restart Word to make sure it was gone, and then reinstall from the Cite pane of the Zotero preferences. But as you say, this is a Word issue, so no particular reason to think that will help.
  • Thanks for suggestion! Repairs did not work, but I have completely got rid of the 32bit version, switched to 64 and everything started working again. Maybe it would help someone.

    I was sticking to 32bit because, duh, it's Word. But it seems like times are changing and maybe 64bit is not receiving a bit more TLC from Microsoft than 32.
  • Well, this has showed up for one of my documents as well, and restarting with a new Normal template did nothing. Trying other solutions based on the threads from 10 years ago.
  • edited July 6, 2020
    Hey everyone, I finally figured out the solution to the 5981 error. In my Office 365 Word 2016, I double checked File -> Options -> Trust Center Settings -> Trusted Locations. In Trusted Locations, click "Add new location" at the bottom.

    Add "C:\Users\[Your Name]\AppData\Roaming\Microsoft\Word\STARTUP\", where the template "Zotero.dotm" should be located, to the box below "Path:". Also click "Subfolders of this location are also trusted". Click "Ok". Then click "Allow Trusted Locations on my network". Click "Ok". Then restart Word and Zotero should work now.

    I went crazy over this issue so I hope it works for you!
  • @ThundaNann: That was specifically for the message "Run-time error '5891': Could not open macro storage"? (And I suspect only the first change you mention was required, not the subfolder setting or the "on my network" setting.)
  • Oh woops, you're right. My error was also "5981".
  • OK, thanks. Actually, I think the original poster just mistyped — it would be 5981.
  • edited 20 days ago
    Hi sir, I have the same problem since a month. I followed the same steps that you illustrated and still it's not working... always a message Erro 5981 is showing up. could you please provide with advice?
    @ThundaNann
  • Did you try switching from 32-bit to 64-bit Office?
  • edited 10 days ago
    No, can You please explain if possible what are the steps to do that?
  • edited 9 days ago
    You would have to uninstall your current installation of Office and download a 64-bit version of Office from Microsoft and install it.
Sign In or Register to comment.