Zotero tab disappeared from Word

This discussion was created from comments split from: Zotero tab is not showing up in Word.
  • Hi there,

    I thought I'd follow this thread because my problem is similar... I hope my message doesn't get lost.

    I have been using Zotero for the past 3 years and have never had an issue, until a couple of months ago when the Zotero tab disappeared from the ribbon in Word. I am a bit desperate by now... [I may well have updated Zotero recently...]

    I have tried every single step on the 'All Plugins/Platforms' site... Strangely enough I thought I had fixed it last night because I managed to recover the tab on one document (only...!), when I tried to add a citation I didn't get a Z bar like in the past but a window with my Zotero library in it, asking me to select the source manually...

    Can any one please help? I am at my wits end ready to move to Mendeley or thelike.

  • @elena%20mancebo What operating system are you using (Windows or Mac), and what versions of Word and Zotero? Can you tell me exactly what you have done as you've followed the steps listed here? https://www.zotero.org/support/word_processor_plugin_troubleshooting#zotero_toolbar_doesn_t_appear

    @dstillman Can we split this to a new thread?
  • Thanks for getting back.

    I'm using Word for Office 365 in Windows.
    When looking for the Zotero version, I have been prompted to download the 5.0.69 version, which I did - tab in ribbon still not there after restart
    Steps I have taken:
    - I have checked that Zotero extension is enabled under Tools → Add-ons → Extensions.
    - I have not reinstalled though
    - I have checked under Word Options that Developer tab and Add-ins are ticked
    - I have checked under Trust Centre
    Zotero is listed under Add-ins, so I'm at a loss....

  • If you have chosen “Disable all macros with notification” for Word macros and don't get a notification then it's worth to try resetting the default word layout template by renaming it to Normal.dotm.bak and restarting Word.
  • Yes! I'm making progress: that worked on my thesis draft doc.... thank you!

    However, the tab was not there when I opened a second Word document, despite the fact that Developer - Add-ins setting are the same... any explanation for that...?
  • Resetting the template or disabling all macros with notification worked?
  • resetting the template
  • Do you have any other addons for Word? If you close all open Word documents and reopen them do you get the tab for any of them?
  • Oooppss.... tab is gone again :/

    Under Active Application Add-ins in Word Options the only stuff listed is:
    Date (XML)
    Instant Messageing Contacts (English)
    Measurement Converter (Measurement COnverter)
    Telephone Number (XML)
  • You should try renaming Normal.dotm to something else one more time and if Zotero tab appears for at least one document it means that another extension that you have is overwriting Normal.dotm and making it impossible for the Zotero tab to show. You could then disable all other extensions, reset Normal.dotm and see if the Zotero tab persists.
  • Ok, so I tried that and the tab persisted across three docs (all within the same folder in OneDrive); when I closed Word and opened another document from some other folder, the tab was gone again...

    I have attempted to disable extensions but there's nothing listed under COM or Word Add-ins...
  • So whatever is doing this is not related to Zotero. You will have to figure out what is causing the breakage/modification of your Normal.dotm. A new user account on the same computer might not have this problem.
  • so, almost a month later, I'm not able to use Zotero... To be honest I have no clue how to sort it out on my own, so this is my last attempt before I start thinking about finding another app.

    Against advice, I reinstalled Zotero, but it seems that atht MS Word add-ins "is not currently installed" (as per meesage under 'cite' tab on Zotero preferences. When I ckicked on "Install" I got the following error message: "Installation could not be completed because an error occurred. Please ensure that Microsoft Word is closed, and then restart Zotero". Does this perhaps give some clue as to where the problem lies...?

    In terms of how the app manifests... The Zotero tab still appears randomly in the first one or two Word documents I open but then it stops appearing (developer box ticked and trust centre settings checked). Despite that, even when the tab is there, I am unable to add citations (ZOtero bar doesn't appear), instead there's a standard MS word edit citation window... existing citations in my document cannot be edited either...

    Any other idea as what I can do or try out as possible solution, please...?
  • Have you tried a different account on the same computer as adomasven suggests?
  • I set up a new user account this morning and zotero seems to work. Glad but....Before transferring all my docs, files etc to the new account to be able to work from it, I have one more question: I work from OneDrive, which I would now need to install for the new account. Is it possible that the issue I have had with Zotero had anything to do with working from the cloud/OneDrive? Do you advise against working from the cloud...?

    Just asking before I set up the new account (that will take some work) although I can't imagine that would have been the issue, since I have worked like that for two years and never had a problem...! I did get a new laptop around the time the issue with Zotero started happening so it's more likely to have been wrong computer settings...?
  • Some people have reported OneDrive compatibility issues, though we haven't been able to reproduce them, and I don't think they involved the Zotero tab disappearing. But in the old account you can certainly try working from a document stored locally rather than in OneDrive to see if that makes a difference.
  • Thanks - I tried that before and it didn't make a difference, no... ok, I will set up everthing on the new user account and work from there. Thanks for the help
  • Hi zotero team, after setting up a new user account on my laptop and gaining zotero function ality at the beginning, the app has become unstable again... Argh...! I say this because when I start my laptop and login, the tap is usually there, sometimes I Cando some referencing, other times I can't. I'll get a message saying there's an error... When I check under add-ons manager, it gives me the option f installing the Ms add-on (even though the tab may have just been there for a few minutes in that session), but I chick on install says 'install could not be completed because an error occurred...'. Any other ideas as to what may be clashing with zotero...?
  • Security software on the system is the most likely possibility. Beyond that, I'm afraid not.
Sign In or Register to comment.