cursor in fields when editing after insertion of citation

advance apologies, in case this has been posted here before, I didn't really know what keyword to look for.

when I insert a citation with the OOo plugin (2.0a2; OOo 3.1) and I continue typing my sentence immediately afterwards, the cursor will automatically be placed outside the greyed field (using fields, not bookmarks) and there is no problem I can just type along. But when I later go back and I want to change the sentence and, say, want to add a comma right after the citation, I cannot get the cursor placed outside the field, the comma will be placed inside of it (and disapper with the next refresh). There are a number of other cases where this problem comes up. Say, I have forgotten to put in a blank space between the citation and the next word and I later want to insert one etc., or also when I rearrange sentences... In fact I have to deal with this not infrequently. Is this a known issue that is being dealt with or is there a work aroung?
Thanks for any pointers to previous discussions of this, should they exist.
  • bump...

    any news on this?
    I'm writing a lot right now, and I have this problem often ...
  • I don't have OpenOffice, so I can't test this, but you could try pressing the right arrow key once you have placed the cursor, that could potentially move it out of the field. Also, does the problem still occur if you navigate to the end of the citation using the left arrow key, rather than the mouse (click a few characters after the citation and tap back to the citation with the arrow key)?

    If you really can't select the position immediately outside the field by any means it sounds like an OpenOffice bug, rather than something Zotero specific (I'm happy to be corrected on this if I'm wrong).
  • no the arrow keys don't help, no matter from which direction I'm moving. I put the curser left of the closing parenthesis and moved right from there. The comma was either added in the greyed field or after the subsequent blank space. The only solution for, say, adding a comma is to insert the comma after the blank space following a citation and then deleting the citation. It's a work around obviously, but only a work around...
  • I suppose in the last sentence you mean "and then deleting the blank space", right? That's the workaround I'm using, too.
  • Someone who uses OpenOffice really should report this if it hasn't been reported already (I did a quick search of OOo issues but couldn't find anything and I feel a bit cheeky reporting a bug with software I don't use). IMO, if you can't select the position just to the right of a field it's almost definitely an OOo bug. Just for reference, the way Word 2007 deals with this is to place the cursor outside the field by default, and then move it into the field on an arrow key press.
  • @adamsmith: sorry, yes, that's what I meant to say...

    I don't know enough about this to guess about the root of this problem or describe the technical details to OOo. I seem to remember, though, there was a discussion about similar issues before the recent OOo plugin was released.
  • edited October 29, 2009
    I can confirm that this problem still exists and it's actually really PITA to work with. Here are my observations:

    * when you place a citation, you will be unable to type after the citation without expanding the field. It does it regardless if you continue typing right away after placing the citation or if you place the cursor just after the citation.
    * normal OOo fields don't behave like this (tried with the date field, insert->fields->date)
    * workaround for this bug is tedious, as you need to go to the next paragraph/segment of text, insert space/comma there and press backspace before the space/comma to go to the place after the citation and then use cursor left to skip the space/comma, and hit enter to make the paragraph division as it was. Also you lose any formatting in the next paragraph as it needs to be merged to the current one temporarily. In case of a heading you need to apply the correct heading style again.

    Should this be reported as OOo bug? Also, is there a way in OOo to edit those fields in "raw" mode so that it would be easier to insert text after them? Ie. [1] would be displayed as <zotero=xyz>1</zotero>? I remember that word used to have this kind of feature, right?

    Edit: forgot to say my plugin versions which are: 2.0b7.4 for Firefox and 3.0a5 for the OOo plugin.

  • +1

    Can this please be fixed?

  • edited December 10, 2010
    This bug persists in current versions of OpenOffice (ooo-build, Ubuntu package 1:3.2.1-7ubuntu1) and Zotero (2.09, OpenOffice plugin 3.0b2).
    It's quite bothersome as one must always type a space, move the cursor back one position and /then/ insert a citation, rather than simply inserting the citation and continuing to type.
    To reiterate on the bug: the integration plugin seems not to close the field after inserting the citation, such that after inserting a citation further text entry is a part of the citation, and is deleted after a refresh or citation change.

    Edit: The above version information and persistence of the bug is correct, however the exact behavior is actually as described elsewhere in this thread.
  • are you sure about the exact nature? I've been using the plugin a lot in Ooo/Ubuntu and if I continue typing immediately after inserting the citation I'm fine and the field ends. It's only if I come back to the end of the citation later that the problem occurs.
  •'re right actually. I must have already gone ahead in my current document.
    It's still pretty irritating...
  • hi all (sorry to revive a long-dead post) -- I was getting annoyed with this problem, and found that switching back to default formatting (hitting ctrl+m) seems to fix this bug -- still not ideal, but certainly easier than inserting a new paragraph, etc.
  • I noticed when I assigned a keyboard command for the citation function, this problem went away for me. I can now add a citation from my keyboard without the cursor getting caught in the citation fields.

    Here is how you add the keyboard commands:
Sign In or Register to comment.