problem with zotero replacing incorrect citation fields in MSword

Recently I have found that zotero is randomly substituting different sources in the field codes in texts I am working on. This doesn't happen to all codes, but rather I notice that a citation has been changed to a different author -- when I did not edit the citation. I have tried to reinstall zotero to see if it helps. Ideas?
  • If you click add/edit citation on those citations that have changed, do they have different cited items? Does it happen in small documents and can you reproduce it?
  • When I click on add/edit, it shows the correct citations. Then it will correct them back after I hit enter again.

    Also, I forgot to mention - the references remain in the bibliography/works cited at the end of the doc even when they don't appear in text bc they were replaced by another citation.

  • Does this happen in multiple, or only a single document? Is there anything you can do to trigger it? What version of Word is this?
  • So far it has happened in 2 different documents, with different citations.

    Not sure how to trigger it since it doesn't happen to all citations but only selectively.

    I have taken screen shots to show how it changes the citation once you click on add/edit, but I'm not able to upload them here.
  • You can upload screenshots to any free image hosting site (, dropbox, google drive etc.) and link to them here.
  • and 21/22 are other citations? If you click on the same citation again, do Topol and Hand come up or the originally cited works?

    I'm guessing this is somehow related to track changes, but still shouldn't happen of course.
  • Initially the document text appears to cite 9 and 10 (two incorrect citations).
    Then I click on add/edit, and in the zotero bar, it indicates Topol and Hand (the correct, originally cited references).
    Then I hit return, and zotero corrects the citation to list 21 and 22 (Topol and Hand) - which is what it was originally, and as it should be in the text.
    If track changes are on, it then goes through and lists all subsequent citations as "field code changed".
    The problem is that when working with a document with hundreds of citations, I can't go through and check each one to make sure it's actually correct...
  • You may just be triggering a citation update by editing the citation. Clicking "Refresh" should do the same thing for the whole document.
  • Hitting refresh does not alter the in-text citations.. they remain listed as 9 and 10 in this case. I have tried this. It is only when I click add/edit that the actual citations appear in the zotero text box (21, 22).
    But when I click add/edit I am not actually editing the citation, I am just opening it and hitting return.
  • In going through this document again, it seems like it is possibly triggered when a citation in the text has been manually edited.

    For example, if, after inserting the citation (20, 21) a space had been manually inserted or deleted, then these citations were incorrectly changed by zotero to list other citations (9, 10).

    So far I have only had this problem when using citation formats that use numbers - never when I use an author-date format, like with Chicago.
  • Oh, yes -- you should never manually edit citations, that will prevent them from updating correctly. What's not right, though, is that you don't get a warning -- clicking refresh in such a situation should pop up a warning for every modified citation and let you decide what to do. Not sure why that wasn't the case.

    One thing you could try is if switching to a different citation style and back has that effect. Refresh _should_ do the same, but apparently doesn't always.
  • Okay this makes sense then. I've never had the problem before when using author-date formats because the citation stays the same after being manually modified, regardless of the fact that it isn't updated when the document is refreshed.

    But, when using formats with numbers, then the citations that have been manually modified appear to be incorrect because they aren't updated with the rest of the document, but then when you click on them to edit them they still have the correct references in the zotero text box.

    Thank you!
  • So if you click Add/Edit on these citations do you get a prompt that they have been modified, or not? If not, could you produce a new small sample document that reproduces this problem and send it to with a link to this thread?
Sign In or Register to comment.