Help: How to Un-Capitalize Capitalized Words in Footnote (Mendeley)

Hello everyone! I have a minor (but really bugging) issue here, I asked the Mendeley care line they told me to ask here.

So whenever I insert footnotes or put in a bibliography with Mendeley, the software automatically capitalizes every first letter of every word (author name, or title). Is there any way to change this? Because sometimes there are words that are not supposed to be capitalized, like how the name Shafi'i is auto capitalized into Shafi'I, or the book name Bidayah wa Nihayah is capitalized into Bidayah Wa Nihayah, and others.

So far the only solution I find is to manually literally editing every single thing after everything is done. But Im writing a dissertation with, like, maybe 600 or more footnotes.

Help, anyone? Thank you!
  • The simplest solution is to enable the Language field for relevant item types (under Tools-->Options in Mendeley) and then add the language or two-letter language code for the non-English language used.

    There are more involved options that allow you to keep auto-capitalization but disable it for individual elements of a title, but this is simple and will work in most cases.

    Technical note:
    @fbennett could we disable autocasing after ' if it's not either at the beginning of a title or preceded by a space?
  • It doesn't capitalize the final i in Shafi'i for me here, neither when as a name nor as a word in the title.

    In any case, Mendeley support should contact me directly if there is an issue with the processor in their environment.
  • @adamsmith sorry, but how to add those things? I opened the menu as per your instructions, but I cannot find the place to insert it..

    PS: Im not too tech savvy T_T
  • @fbennett somehow it does for me.. I wonder why... Or maybe its because Shafi'i vs Shafi'i? (different direction of the upper comma, whatever its name is)
  • edited 11 days ago
    Your examples there (Shafi'i vs Shafi'i) both show the same character (close-single-quote, or "apostrophe" in this context). There are a few possibilities:
    • If by direction you meant open- vs close-single-quote, that would be "Shafi`i vs Shafi'i", and in that case I again don't see capitalization in the processor
    • If by direction you mean that one was entered in right-to-left mode (as for Farsi, Arabic, or Hebrew), and the other in left-to-right mode (as for other languages), the advice would be to use LTR punctuation in LTR text
    • If you are not using an RTL apostrophe there, then there may be some other cause.
    If the first or the last item in that list describes your issue, I'll need to know exactly which processor version is used, exactly what options are set when running it, and exactly what input it is seeing from the client (Mendeley Desktop). The people at Mendeley care line should be able to provide answers to those questions, and you should ask them to contact me. If they no longer have my email address, I can be reached through GitHub (https://github.com/Juris-M/citeproc-js/issues) as the best way to address your issue.
  • @fajrimuhammadin sorry, you'll have to contact Mendeley for usage details, we can't really help you here beyond what's relevant for the citation styles. (Or, of course, you could use Zotero, for which this solution is well documented)
  • I see... The thing is the Mendeley care center asked me to ask this forum hahaha...

    If that is the case, I guess it should be possible to migrate everything from Mendeley to Zotero right? So I can just fix everything from there?

    Thank you everyone!
  • It’s easy to migrate from Mendeley to Zotero. See here for the best method https://www.zotero.org/support/kb/mendeley_import
  • Yes to the migration instructions. However, if you've already authored a document using Mendeley, while the citations will continue to work, you won't be able to update their metadata from Zotero, so this may not be an ideal solution if you're far along with writing.

    In that case, do ask Mendeley support to help you based on my feedback above. They should be able to understand that.
Sign In or Register to comment.