bookmarklet not working on ipad (2011) safari browser

Anyone has tried using the bookmarklet on ios in safari. I tried bookmarking on a pdf and it looked like sth was happening but in the end I was redirected to an empty page. Anyone with similar experience who might have solved the problem?
  • The bookmarklet isn't able to run on a PDF for technical reasons. You have to run it on a regular webpage.
  • Still doesn't work, here's a webpage and not the actual pdf. I'm not able to bookmark it to zotero, pressing bookmarklet does nothing.
  • Oh, this is a 2011 iPad? What iOS version are you running? If you're not able to update to a recent iOS version, you may not be able to use the bookmarklet.

    You can still copy URLs or identifiers into the save page.
  • edited June 4, 2019
    (If you're seeing the Zotero login page in a frame despite being logged into Zotero, that's a different issue, but if nothing is happening your version of Safari may just be too old.)
  • I'm running iOS 9.3.x , the save page link is a nice touch unfortunately it doesn't work on safari. The page doesn't display properly the option of search bar input doesn't show at all on ipad but works on desktop via chrome.
  • the option of search bar input doesn't show at all on ipad
    I'm not sure what you mean by that. Can you upload a screenshot somewhere (e.g., Dropbox) and provide a link here? The page certainly works on current versions of Mobile Safari.
  • edited June 4, 2019
    This is what I see on safari on ipad. That's what I meant it doesn't show the search box compared to visiting via a browser on my desktop pc. Basically the way that it is shown right now on ipad/safari makes it impossible to paste any url or arxiv ids to search and save stuff to my library contrary to how it works and looks on desktop browser (chrome)
  • Is this the correct bookmarklet code? If so then from here it seems that any spaces are replaced by %20d, I had a similar issue with the bibsonomy bookmarklet until the folks there pointed me into another bookmarklet code which didn't had any spaces and that apparently worked compared to previous attemps.
  • Don't worry about the spaces. The code is correct.

    For the /save page, see my response in your other thread.

    The current version of the bookmarklet doesn't support Safari 9, but we serve Safari 9 an older version of the bookmarklet that should work. That's not something we can spend time on at this point, though, so if it's not working for you, I'm afraid you'll need to use another method to save.
Sign In or Register to comment.