Citation count

In Zotero 5, is it possible to pull the citation count for an item (i.e. the "cited by X" from google scholar). Ideally I'd like this to go on it's own field which I can sort items by.

A long while ago when I first used Zotero as a browser plugin there was an add-on that did exactly this, but now can't find a way to do the same.
  • The add-on is still available: https://github.com/beloglazov/zotero-scholar-citations

    Though note that given google scholar's stricter bot detecting policies, I would expect you to get locked out of google scholar repeatedly when using it.
  • @adamsmith many thanks, that's exactly the one.

    Looks like the original repo is no longer maintained, but found a fork that is actively maintained, and it seems to work well: https://github.com/MaxKuehn/zotero-scholar-citations
  • @ktorn Hi! I tried to install this today and am getting a message that it is not compatible. Are you actively using this on the current version of Zotero?
  • How are you installing -- note you need to download the .xpi file and the install in Zotero from tools --> add-ons. If you just click on the file in Firefox you'll get an error.
  • yes, I downloaded the .xpi. when I attempt the "Install Add-on from file" in Zotero, I get the error: "The add-on "Zotero Scholar Citations" could not be installed. It may be incompatible with this version of Zotero."

    I'm at version 5.0.60.
  • That'd be the problem. The minimum Zotero version is 5.0.66 (and there are all sorts of reasons to update to 5.0.74 anyway)
  • Thanks! Not able to upgrade easily at work due to security restrictions, but will do it at home.
  • I installed the latest Zotero on another laptop and then the add-on (no errors). My Zotero library was large, that when I restarted Zotero to activate the add-on, Google Scholar screamed at the traffic from the add-in because my Zotero library is large, so I had to kill Zotero from task manager (no other way to interrupt the process). I created a new zotero profile with just the folder of docs I wanted citations for and now cannot get the add-in to run and collect the citations. I've unsynced/resynced my Zotero account. Closed and reopened Zotero. Restarted the laptop. Disabled/reenabled the add-in. Any ideas how to get the add-in to run now? Thanks again!
  • Just to check, you have the version from here installed, correct?
    https://github.com/MaxKuehn/zotero-scholar-citations
  • Yes...2.0.4 that was released 3 days ago. Just downloaded the latest Zotero as well. 5.0.74
  • If you go to Google Scholar in your web browser, does it load?
  • I can open Google Scholar in my browser (just did). I don't see anything happening still in Zotero...no citation counts showing up in the "Extra" field and no angry captchas from Google Scholar. If GS had cut me off, I would at least be seeing pop-ups about that, correct?
  • After you install it and run retrieve citations for one item, do you see any errors in the Error Console in the Help menu?
  • Sorry for the pause! Actually one of my questions is that I don't see any options to start the Addon...how do you trigger it to retrieve citations?
  • Right click on the item or collection and choose Update Citations
  • This is Linda again (different login account). I got the addin to run once, then it failed when I tried to run it again on a different batch. Here are the errors
    Timestamp: 9/10/2019 11:28:43 AM
    Warning: Unknown property ‘user-select’. Declaration dropped.
    Source File: chrome://zotero/skin/overlay.css
    Line: 647, Column: 12
    Source Code:
    user-select: text;
    Timestamp: 9/10/2019 11:28:43 AM
    Warning: unreachable code after return statement
    Source File: resource://gre/modules/commonjs/toolkit/loader.js -> resource://zotero/bluebird/util.js
    Line: 201, Column: 4
    Source Code:
    eval(obj);
    Timestamp: 9/10/2019 11:29:14 AM
    Warning: Key event not available on some keyboard layouts: key=“i” modifiers=“accel shift alt” id=“key_importFromClipboard”
    Source File: chrome://zotero/content/standalone/standalone.xul
    Line: 0
  • Hey! Update. After that one brief time that the add-on worked, I was unable to get it to run again when I had my complete set of docs to check. I tried uninstalling Zotero (deleting all residual files), reinstalling Zotero and the add-in. What finally worked (briefly) was disconnecting from my work's guess wifi and connecting to my phone's hotspot. So maybe Google Scholar's blocking was the issue. (my paper set size is 248).
    I was wondering if you've considered trying to do this with lens.org. They base their dataset on Microsoft Academic, which is Bing indexed (as opposed to Google Scholar's google indexing). Their dataset is cleaner, though, because they also incorporate CrossRef. Not only do they not captcha, they have a free API. I'm comparing bibliometric data across multiple resources. google scholar's citation counts are considered highly questionable by experts in bibliometrics. When I did detailed some sample checking, I found citation counts inflated by counting the same paper's references multiple times just because it was posted to several websites (google failed to dedup) and citations off of undergraduate papers being counted. IMHO google scholar is our grandma's academic search engine. ;-) the one benefit I'm trying to reap here is that one of our flagship publications is not represented well in Lens or MicAc because our publications folks aren't posting it to crossref at the chapter level, which is how folks are citing it. I'm having to harvest the [citation] entries from GS to get proper citation counts, but that's our pub folks' fault and they will soon be fixing that.
  • That sounds like Google Scholar blocking you, yeah. In terms of counting of citations, Google Scholar has the most comprehensive coverage by far, so you are likely to get underestimates from other sources. It would likely be possible to retrieve citation counts using lens.org/Microsoft Academic if they have an API. You could potentially talk to the maintainer of the Google Scholar Citations plugin to see if they are interested in writing a similar plugin for another source of data.
Sign In or Register to comment.