Bibliography Problem

I am trying to create a bibliography for this (large) document. Zotero is unable to do it for some reason. I have tried to do your troubleshoot procedures but that have been unsuccessful. I have done this kind of thing before: not sure why it is giving me problems now. I sent a version of the document to

Can you help? thanks.
  • edited June 1, 2019
    How long is your document? How many citations? What exactly happens when you click Add Bibliography?
  • It's a book length document with probably 800 citations in all? When I click 'bibliography' it just stalls then says something along the lines of 'unable to complete task.' 'troubleshoot.' etc.
  • We'll need the exact error message. Note that with 800 citations it can take a while to generate the bibliography, so you may need to leave it for a short time. But if you're actually getting an error message, that may indicate a different problem.
  • edited June 3, 2019
    I assume you are using a Mac. Unfortunately, Word for Mac integration is very slow and tends to produce issues like the one you are seeing. On the other hand, you have over 1100 citations and pushing both Word and Zotero to their limits for this. You could try generating the bibliography overnight. Make sure Word is updated to the latest version and try run the operation after restarting the computer and without any other applications open.

    If running overnight doesn't help, you can either split the document into chapters and generate the bibliography separately, or alternatively, try doing it on a Windows PC with Zotero installed (you do not have to have your Zotero library synced to the Windows PC for this to worked), which will probably take under 10 minutes there.
  • I have the same problem - i've seen a number of posts about the issues with word (onedrive) and macs and am not sure what I can do. My thesis is now up to nearly 75000 words and there will be hundreds, if not over a thousand, citations. If i cut and paste from the document into a smaller one, it will produce a bibliography, but it won't do it for the full doc. Manually putting them back in, and reordering alphabetically will take forever. Is there any workaround for this at all? I would be happy to use different word processing software, but don't have access to a PC (and we are currently in level 4 lockdown in NZ..) thanks in advance!
  • @smkember: How long have you waited in the full doc? As Adomas says above, it could take quite a while, and you should try leaving it overnight if you haven't.
  • Thanks - I left it for six hours but will try overnight. I saw a post about a progress bar but I can't see that, and there is nothing to indicate that my document is doing anything at all.
  • You can go to Help → Debug Output Logging → View Output in Zotero to see if anything is happening while you refresh.
  • Thank you, will do
Sign In or Register to comment.