Drag and Drop PDF has stopped working


Zotero 5.0.66, Windows 10.

Previously I have been able to drag and drop PDFs into my library but it has stopped working. All I get now when I try is a circle with a line (like a no entry sign). Since I last used this facility a couple of days ago two things have happened:

1. Windows has updated
2. I installed Amazon Corretto so I could run a Java App

I've tried re-installing Zotero and uninstalling Corretto but neither have made any difference. There are no errors reported by Zotero.

Any suggestions on what else I could try to get this working again?

  • Have you tried restarting your computer? Have you tried different files, from different locations on your system?
  • Thanks for the quick response. Should have said, multiple restarts and tried files from different locations, including one of the same PDFs I dragged in a few days ago.
  • Can you still add with "Store Copy of Fileā€¦" in the New Item (+) menu?
  • Yes, just added the reference I was trying to drag using that option
  • This isn't a general problem, and It's unlikely this is a problem in Zotero itself, so you'll probably need to debug this on your own system, but see this thread for a potential fix.
  • Thanks for the link - I didn't see that when I searched. I suspected a security issue after the windows update and did venture into those settings but I assumed Zotero would need to run as an administrator so will go back in and make sure it's not.

    If I find a solution I'll report back.

    Thanks for the help
  • Well that solved it :-)

    There must have been a mismatch after the update for some reason (probably never know why) and I'd compounded it by assuming Zotero needed to run as an administrator. Have just un-ticked every "run as administrator" box I could find for the .exe file and shortcut and all is well with the world again.

    Thanks again for the help
Sign In or Register to comment.