Preserving Word formatting (italics/bold) in Zotero cite fields

I didn't see this discussed before (sorry if I missed it).

I'm currently trying to insert a cite (no special text in it) within an italicized paragraph in Word. When I do so, the cite de-italicizes. I can set it to italics again in Word, but this disappears when I refresh the cites in Zotero. I've tried reinserting, even copying/pasting another cite that happens to be formatted as italics already.

Is there a trick to this, or some way to reset it or ensure the formatting is preserved? Basically I'd like the Zotero field to act like plain text and inherit whatever formatting Word has set for that paragraph.
  • It seems that if I highlight exactly and only the Zotero field and then specifically italicize that in Word, it may preserve that formatting after a refresh, but not when I select and format the whole paragraph.

    Am I on to something?

    (Word 2011 on Mac)
  • I'm afraid there is no purposeful way to do this. It's possible that what you found works, but that would be by chance/accident, not by design, and thus not necessarily reliable.

  • What would you recommend in this case?

    I've seen this come up before but it was jut a curiosity and not a practical issue. I don't often write in italics (or bold), so this hasn't come up before, but in this document I have a long table, in which some of the cells contain notes in separate italic paragraphs.

    Is there a way to set it up to begin with to work well, or should I just manually recheck italics after?
  • Zotero applies the current Word paragraph style (Normal, Heading 1, etc.) to the citations when it inserts them. When you select a whole paragraph, any direct formatting (e.g., Normal+Italics) gets recorded in a different way than if you select only a few words. That is probably the source of the different behavior.

    If you are doing this sort of markup a lot, you should just make a new Word Quick Style (e.g., call it Emphasis or Quote or something) with the italics and other styling. That will get preserved without issue because Zotero will apply that style, rather than Normal.

    Another more brittle option would be select the whole paragraph, but carefully avoid selecting the paragraph break character at the end (the extra white space at the end when you select the whole paragraph/the pillcrow symbol if you have formatting marks visible). Then, apply italics/etc. to make these formatting changes as text-formatting instead of paragraph-formatting. Obviously, this is much more involved than making s Quick Style.
  • Thanks for those tricks. No, I won't do this a lot, but it's good to know some workarounds for when it comes up.
Sign In or Register to comment.